Main Site Documentation

Device has old or unsupported configuration error :'( :'(


#1

hello I have fez panda II but when I test on deployment tool I take this message what should I do please help me :’( I didnt use for a long time :’(


#2

but when I try to ping, I take “Pinging… TinyCLR” message


#3

when I try on visual c# I take "Error 1 An error has occurred: please check your hardware.
" message


#4

Mfdeploy can only be used to ping panda and to get version number. Nothing else is supported.

Other fez support everything.


#5

Is this related to #1 note when you click reply? :slight_smile:

Welcome to the community.


#6

what will I do to use my fez panda :frowning:


#7

undate your firmware. http://wiki.tinyclr.com/index.php?title=Firmware_Update

That is the BEFORE YOU SUBMIT pointer #1 that Gus mentioned earlier. When you reply to this post, look for the link. Click it. Follow the instructions. Then try again.


#8

I updated my firmware to 4.1.8 it was no problem

when I send ping there is no problem

when I check my version on deploy tool it is correct 4.1.8

when open in visual c#, I took this error message :frowning: Error 1 0xfd000000 C:\Users\SONY VAIO\AppData\Local\Temporary Projects\FEZ Panda II Application1\MMP FEZ Panda II Application1

what does it mean

what will I do to use my fez panda II


#9

Have you tried these exact steps http://wiki.tinyclr.com/index.php?title=First_Project


#10

yes when I try first project there is no problem but when I start new project->fez panda II project, and debug blinking led I take this error


#11

Then you still have unmatching firmware.

Do not make any changes in new created projects and …

  1. load console application, does it work? This should not fail
  2. load panda II blink LED, does it fail? If fails, you do not have the correct firmware.

#12

yes console application is working correctly but when I apply blinking led error I get is

------ Deploy started: Project: MFConsoleApplication1, Configuration: Debug Any CPU ------
An error has occurred: please check your hardware.
Object reference not set to an instance of an object.
Source: Microsoft.SPOT.Debugger.CorDebug
Stack :
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 893
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


#13

my firmware is

ClrInfo.clrVersion: 4.1.2821.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.1.2821.0
SolutionReleaseInfo.solutionVersion: 4.1.8.0
SolutionReleaseInfo.solutionVendorInfo: GHI Electronics, LLC
SoftwareVersion.BuildDate: Dec 22 2011
SoftwareVersion.CompilerVersion: 410561

release note:

Important note: Requires .NET Micro Framework 4.1 and Visual Studio 2010

• USBizi (FEZ Mini, FEZ Domino, FEZ Rhino, FEZ Panda) V 4.1.8.0
• EMX (FEZ Cobra) V 4.1.8.0, TinyBooter V 4.1.6.0
• ChipworkX V 4.1.8.0 TinyBooter V 4.1.5.1
• GHI NETMF Library V 4.1.8.0


#14

please help me I have school project I need this device :frowning:


#15

I do not quite understand the first statement. If I read it correctly, you have a project that you used to use with your Panda a while back. You updated the SDK and the firmware on the Panda, the project builds ok but when you deploy it you get the error.
If that is the case, then your need to go the the references list in the project. Make a note of the references you have selected. Delete all but the “mscorlib” and re-add them. It is possible that the references are pointing to “old” SDK assemblies.
If I am way off base on this I appologize, its just that I recently reserected an old project, replaced all the references that had warnings on them (trying to build with the warning tags on the references gives you a build error). When I tried to deploy, I got the same error you have. Once I replaced all the references, my project worked.
Who knows this may work for you, it can’t hurt.


#16

thanks for answer… when I had 4.1.5 firmware I took this error cause of this I updated firmware but nothing changed
new event :slight_smile:
I tried without fez_pandaII_GHIelectronics reference I didnt take this error but code didnt work

code is this

using System;
using Microsoft.SPOT;
using System.Threading;
using Microsoft.SPOT.Hardware;

namespace MFConsoleApplication1
{
public class Program
{
public static void Main()
{
OutputPort LED;
LED = new OutputPort((Cpu.Pin)4, true);

        Thread.Sleep(Timeout.Infinite);
    }

}

}
there is no change pin4


#17

have I warranty about this device?


#18

What language are you running on windows?


#19

You still need to have the references.
The failure to work may be due to the missing references. My point was that you needed to replace them.


#20

I think he is seeing the known problem with Turkish locale.