Main Site Documentation

Device Descriptor Request Failed


#1

Don’t can me if this is covered, I can’t find it. I made up 3 custom pcb using g120’s. I’ve made heaps with g120’s before. However one of them won’t connect to the pc in usb mode. It’s fine to update the firmware with fez config. and operates fine when in serial/com3 mode. But connect it strait to usb and it’s no good. says unknown usb device connected. the weird thing is, not only do the other 2 boards work fine. But this board also works on another PC? just not on this one? Any suggestions?


#2

Update.

Sending the .ghi file to it via teraterm fixes it almost. While only tinybooter is installed, it shows up in the device manager properly. Only I can’t use it obviously without the tinyclr. when I run fez config to install it. the problem comes back the same though. Is this a type of failure that is seen on these SOM’s?


#3

I ran into a similar situation so once in a wile and sometimes removing the usb driver for that device did it or the last time I just used a different USB cable …

Now this is not a scientific approach but did the job on my side


#4

After trying everything, I went back to the pc I thought it was working in but it really wasn’t, It did appear as a g120 but was frozen and wouldn’t do anything else. I cranked up the reflow station and moved it to another board and the problem moves with this g120. Think it’s busted, Replaced it and the new one on the same board is fine. Bad luck I guess.

Thanks