Main Site Documentation

Deployment errors


#1

I pressed F5 on a project that worked yesterday and now I get a dialog box “There were deployment errors. Continue?”. I also get a message in the error list: “An error has occurred. Please check your hardware.” I then ran a different project w/o issue. Re-tried the now-bad project and got the same error. Restarted VS (2010) to no effect.

I copied the contents of program.cs (the text, not the file) into a new solution and it deploys/runs fine – without changing the code at all.

How do I go about getting more info on this error / anybody already know what’s up?


#2

Some options…

Make new solution and try again
restart VS2010
restart the PC
restart the board


#3

I did restart the board and VS2010 to no avail. Didn’t restart the PC 'cause other solutions worked.

I made another solution, with identical program.cs and references and it worked. Looking to get info here as to why I should have to? The error message doesn’t point to where to start the debug process.


#4

This happened again, with a completely different .sln. Maybe some more information:

It was the first sln opened after launching VS2010 after a cold reboot of the computer. I hit F5 after changing some minor things in the code (which pin a digital out was pointing at, nothing involving assemblies, etc) and immediately got “Visual C# has crashed, send error report?” or words to that effect. I clicked “send” and VS restarted. I reloaded the .sln, made the same changes and hit F5. Got the deployment error message as below. This time, I used “save solution as…” to rename the .sln and the new-named version worked fine without any further changes.


#5

I never had any similar problem


#6

seems I’m not the only one having VS crashes.

nobody else mentions the corrupted sln, though.


#7

I’ve been pooched by this quite a few times before
and now I got the Fez Panda II boards for like 10 minutes and I run into the exact same thing again…

This is pretty scary when working on real products


#8

Apparently VS throws this exception when it has an issue with the referenced assemblies or assemblies that are not referenced but should be…


#9

If you can reproduce the error then please post it here www.netmf.com


#10

I have the same error sometimes. When I restart the board or restart VS the problem is solved.
I think the board is freezed at some point.

Didn’t figure out why this error comes and goes…


#11

I have a problem where I build and deploy to the device and it works perfectly once, then I change something in the code (or just re-deploy) and VS sticks at the “Preparing solution for deployment” or whatever the message is at the bottom of the screen. Restarting VS allows me to do one more deploy, and then I have to restart it again.Restarting the dev board doesn’t solve the problem, and the board isn’t frozen.


#12

Hi,

I got the exact Problem Ron2 is describing.
So far the only “Solution” that doesn’t involve completely restarting my Comp is going into my hardware manager and deactivate the usb driver.
But you have to make sure to close VS before you do that else its not letting you reactivate the driver without a restart of the computer anyway.

So still have to wait like a minute till he notices he can’t deploy and finally lets you controle VS again.

First I also thought the board was frozen, but makes no sense when you disconnect it and you get the same error, restart the computer and your fine. I think it actually worked with the terminal when the deployment failed, just the ping test couldn’t be performed. Got me looking at the drivers. Anyway

Other than that, I love my Panda II. Srsly, I got to say great job!
I’m still at the start of my Projekt, but the more I use the Libraries the more I like it.

It’s not my first µC Projekt, have been working with little 8 Bit Atmels before and C/C++
I have to say first I was afraid when I saw everythings hidden in Classes where you can’t
check whats actually written there, but just a few days in I adepted that.
Pretty much everythings going to be classes and the main Programm, probably more like
empty with a few Thread calls. However you can still actually go down Hardware level without
losing any of the Benefits. Love it.

Won’t be my last board for sure :smiley:

Like it took me long to set up some I2C on the Atmel, but I’m not even sure if it works,
and with Fez I was able get my Sensor (Wii motion Plus) to work in a few hours (with soldering and a
mindblockade on what was wrong on my program, sensor worked nonetheless. I just made a missleading debug message :3

Well blablabla, cya ^^


#13

Have you guys tryied ot use a power source or powered hub to power your device? It could be all related to weak power that causes some problems on USB, which could be the cause of crashing VS?

Thanks for the support and welcome here


#14

I will try the suggestion with the power once I crafted a dedicated batterypack for the panda.

However, I doubt thats the reason.

Just this morning I quickly wanted to try something before going to university but it didn’t deploy.
Since I was low on time I didn’t do the regular shutdown of the Driver. Shut down my PC and leave the house…

When I came back I saw BSOD that I had seen before when trying to shut down the Computer after FEZ VS didn’t deploy. Says something like “USB_DRIVER…something something” in the Header given as a reason and tells you, to check for recently installed Hardware. That screen appears when I shut down and than my desktop vanishes regular, but when the screen is all black with the windows simbol in the middle it stays like that for ages till it reaches that BSOD. Makes a Crashdump of my mem and waits till I turn of manually

Running 64Bit Win 7 on a Gigabyte Chipset here if thats any help to nail the problem.

Afterall, who knows. Maybe to little power on the board sometimes ends up putting the driver in an erornious state.


#15

I’ve had driver issues as well, also resulting in a BSOD on reboot.

I’m using the 64 bit version - Possibly something to do with that, since the majority of people aren’t experiencing this?


#16

+1 to using x64, but -1 on BSODs.


#17

It’s like I said before, if VS gives you “check hardware” or "hardware error"
it can mean anything… your best bet is to look at the output window
while it’s trying to deploy.

Side note:I’ve been using 64 bit Windows ever since the first 64 bit version was released.


#18

For whatever it’s worth, I’ve found another way around this problem.

If I disable and re-enable (in Windows) the USB hub to which my Panda is connected, the problem goes away.

The disable/re-enable is done through the Device Manager in Windows, in the “Universal Serial Bus controllers” section.