Main Site Documentation

Deployment BUG?


#1

Hi

we have maybe encountered a bug/problem with the deployment, namly
the usb debug interface has gone unresponsive 2 times after trying to run softi2c example (from code.tinyclr)

the symptoms are that VS freezes in deployment attempt
mfdeploy sees usb device, but ping says that there is no response…
after REFLASHING the board is again responsive…

maybe it is not yet sufficient testing, but it has happened 2 times already, I be trying a few more times

Antti


#2

Happened to me couple of time too.I solved it by resetting the board (Cerberus) while it is trying to deploy. After that it continues through the deployment successfully. Can be a different issue, though.


#3

Yes USB needs work still.


#4

i think there is some issue, it is however weird that it happened with specific application ,not random so maybe somehow the deployment did write to wrong place,… it would then be not usb issue but something else… i check a few more times if the same application really always corrupts the firmware or not

Antti


#5

I had the same problem yesterday… the USB device was seen by msdeploy but wouldn’t ping. I also reflashed and it worked again. I was working on my I2C code at that time.

But I did use that same code over and over with little to no modification as I was testing the hardware (pullup resistors) mostly…

I tried the same code again plenty times but didn’t run into this issue again… so at this time I’m not sure it’s easy to reproduce…


#6

ok, here are findings, I can upload the project for problem replication

tinyclr.com soft i2c demo, 1:1 taken same source code

compile, ok, deploy ok, START also…
next deployment… freeze no ping, need reflash the all chip

funny thing is that: on our hardware

  1. nuttx RTOS can not properly work with i2c, with debug enabled it partially can succeed with i2c device scan, but with debug off it just timeouts when it sees any i2c device responding
  2. .NET i2c scan (hw) fails
  3. .NET i2c software scan gets timeout excpetion as soon as it sees device giving ACK (and also corrupts flash!)
  4. C sample code for STM32F4disco also seems to not be working with i2c :frowning:

very weird… I have written soft i2c many times, it seems maybe i need todo it once more to
get it working on F4

Antti