Deploying and debugging EMX over TCP in incredibly slow

Hello everyone,

so I have this nice piece of hardware — EMX development board. I want to use USB for other purposes, so for deployment and debugging I try to use Tcp (with static IP address). In the beginning it behaves normally: Visual Studio connects to EMX, deploys application and restarts hardware. Looks good, but that’s where my success ends: the whole process stops for a couple minutes (!). I guess Visual Studio is trying to attach the debugger during that time. It succeeds, eventually, and from that moment on everything looks normal again — I can step through the code without delays.

Is such behaviour normal? These three or four minutes makes debugging over TCP totally unusable. Could this be due to problems on my PC, or am I missing something about EMX?


Last time we rested tcp debugging was couple years ago and we didn’t see such delay.

Welcome to the community.

I have tried to debug on a different PC — same thing. I guess the problem is ont the EMX side. Gus, do you have an issue tracker so I could open a case?

you’re in it :slight_smile:

I have figured it out. EMX set its IP address to at boot up, no matter how the network settings are configured. Since my computer is on different subnet (192.168.11.x), Visual Studio has problems attaching to EMX. I installed another LAN adapter, manually set its IP address to, and now it works! Could work faster, though, but that’s a good start.

or you can open MFDeploy…
choose USB and pick your device, next click on Target>>Configuration>>and change the IP from to which will force VS studio to wait on an Actual IP before trying to deploy…

let us know if that works… if it doesn’t then change it to the one you have assigned by your router…