Main Site Documentation

Deploy Transport USB Device <none>


#1

I’ve got the firmware installed using FEZConfig by moving the Cerbuino Bee to a USB 2 port.

Now when I start VS2010 it doesn’t show up in there. I’ve uninstalled and reinstalled all of the drivers.The board shows up in device manager as a GHI NETMF Debug Interface and Devices and Printers shows it as Cerb-Family.

https://www.ghielectronics.com/community/forum/topic?id=14654


#2

Hi Mike,

usually when this happens it means the Gadgeteer app can’t connect via the default name - if you renamed the device perhaps, this can be seen. The good news is it’s simple to fix - simply open the project properties (right click the project name in the solution explorer) and go to the .Net Micro Framework settings, change the “transport” to serial and then change it back to USB, and the name that appears in the Device box is what is currently connected. Then you should be able to deploy.

good luck !


#3

I’ve changed to Serial and back to USB, no change in the Device box. I didn’t change the name in FEZConfig. I’ve tried to change the Device name but it still doesn’t work. When I change to Serial and back the Device drop down goes back to


#4

Does the device show up in MFDeploy and FEZConfig? What does it display when you ping it in either program?


#5

They both show
USB: Cerb-Family_Gadgeteer
Pinging… TinyCLR


#6

Just for giggles, I installed netmf 4.2 and the GHI package on my Surface Pro. I plugged in the Cerbuino Bee and it showed up in VS2010 but it wouldn’t deploy. The Surface Pro only has 1 USB3 port.


#7

I use a surface pro without issue, i do use a Belkin powered hub with it tho.


#8

I’ll give that a try tonight when I get home.


#9

I uninstalled and reinstalled VS2010 with no change. I tried plugging in my Hydra and VS doesn’t recognize that anymore either.


#10

Can you complete uninstall and reinstall our SDK including the drivers? The following document might be helpful in uninstalling the drivers: https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb


#11

Removed all the .NetMF related stuff. Re installed all the drivers. The Cerbuino Bee now shows up in VS2010 but when I deploy a project it reboots the device and it never comes back. I have to unplug and plug it back in before it will show up in device manager again. I did reflash the entire system again starting with the DfuSe.


#12

Does it reboot because you are trying to debug? Have you tried to deploy a small program that does nothing more than call a debug.print? Does it show up in Visual Studio after you replug it?


#13

Yes, it reboots to debug.
I created a new Gadgeteer project based on the Cerbuino Bee that only runs


The status line at the bottom of VS2010 displays:
    Preparing to deploy assemblies to the device.
    Deploy successful.
    The debugging target is not in an initialized state; rebooting... 

I never see "Program Started" in my output windows.
If I replug/reset the board it shows back up in Devices and Printers and the Properties of VS2010. 
Is there a different driver for debug mode?

#14

Mike, now you have deployed your app, can you leave VS disconnected and move over to try to get MFDeploy talking to the board?

Once you remove the USB cable and reconnect it, have MFDeploy open and selected your USB/Cerbuino combination, then hit F5 to connect. Once that happens, you should see the debug messages - if you get it in time you should get the program started message. If not, try adding a 1 second timer to the app and have it flash the onboard debug LED - that thing by default will print out a message to the debug window, and as a bonus you get the LED flashing if the app is actually working !


#15

I couldn’t get it connect in time to see the “Program Started”, but the light did blink. I tried debugging on my Surface Pro and it is doing the same thing.


#16

Try the blink LED program on the Hydra; both with VS 2010 as output window and trying MFDeploy per Brett’s suggestion. Let us know what happens.


#17

Hyrda has no problem running in debugging mode.
Application deploys and hits breakpoints as expected.