Main Site Documentation

Debugging pauses at p.run()


#1

I recently updated a project to 4.2 on a Cobra 2 and now when I run the code, it is paused as the display and debug output is frozen.

If I hit pause in the debugger (VS2012) it breaks at the p2.run line and then when I hit continue it starts running as normal.

Everything else seems fine once it starts and this only happens when debugging is attached. In normal run mode everything runs as normal.


#2

Hi Dave,
I ran into a similar issue with VS2012 and WinUSB Driver, after debugging for a while my program stops outputting to the output box, and only resumes if I put a break point anywhere in the program, and suddenly my board gets back to work… it’s getting annoying now that it’s more frequent…

can someone help?

Cheers,
Jay.


#3

I have the same issues cropping up


#4

Is there a workaround?
Does it always happen?
Happens on a new project?


#5

The workaround is to pause the debugger and it breaks at p2.run then hit F5 and it will start again.
it hasn’t happened all the time maybe every 5th time.
i know it was happening on the cerb40 but can’t remember if it happens on other products.
i’ll be using a cobra 2 today and will let you know if i see the issue there.


#6

We have encountered this as well but we have no information as to the cause or a fix as of now. When it does happen, it usually happens when a thread is executing some sort of IO call such as socket reading or file writing.


#7

As it happens John, my code is using sockets.


#8

It has happened while i was debugging the cc3000 software


#9

yep i’m using Sockets as well…
but I don’t have to hit the pause button in my case is just putting a break point somewhere in code and off it goes again…

Edit: a tip when I get tired of having those issue I start debugging using MFDeploy…

open MFDeploy, select USB choose your board and, reset your board then click on Target Connect…

and watch your debug info flowing in the box, no hangs :slight_smile:


#10

also happens on G120hdr with the cc3000 codshare program