Main Site Documentation

Debug Gadgeteer project with Fez-Hydra


#1

My apologies in advance,
I’m newbie with Hydra and Gadgeteer, when I try debug a new project get the next message from VS.

Invalid native checksum: GHIElectronics.OSH.NETMF.Hardware 0xFCA3F12!=0xE23395B
Resolving.
Link failure: some assembly references cannot be resolved!!
Assembly: GadgeteerApp1 (1.0.0.0) needs assembly ‘GHIElectronics.Gadgeteer.FEZHydra’ (4.1.1.0)
Error: a3000000

The GHIElectronics.Gadgeteer.FEZHydra, referenced is correct (4.1.1.0)

any suggestion?
Thanks,


#2

Common mistake. Please click reply and look at #1 :slight_smile:


#3

Gus… I saw Please click reply and look at #1

What reply? I have no idea what you want clicked.
OK so I’m not the brightest street lamp on the block…

I only wanted to see the answer.

Thanks


#4

The “Reply” button at the bottom of this page.


#5

ianlee74

I did that and it takes me to the normal blank reply page.

I did not want to make a reply, I just wanted to see Gus’s answer @ ‘Please click reply and look at #1


#6

See attached image please. This is when you see when you clock reply. You need to update your firmware.


#7

Hi All,
In this case, the problem was not the firmware. The problem was I’m trying play with both versions of Gadgeteer (4.1 and Beta 4.2) and MicroFramework 4.2 in the same desktop, after uninstall and setup the GHI installer all work fine again.

Watching the Spider firmware update software I have found (see next image) and I think that is a mistake… maybe with labels, Tinybooter label are pointing ‘Config.hex’ and the Firmware label are pointing to TinyBooter. Anybody here have succesfully update the spider firmware using this app?

Thanks,
PepLluis,


#8

The updater application works fine but maybe we have the text placed backwards. We will check.


#9

That is the old version of the firmware updater. Could you try downloading the latest SDK and then trying it again?

The SDK can be found here: http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20and%20.NET%20Gadgeteer%20Package.zip


#10

Thanks for your feedback, this bug was fixed.