Main Site Documentation

Could connect to Domino, cannot connect Panda


#1

Hello there!
I had a Domino 2 weeks ago, but I killed it (stupid shortcut with my power supply!!)
I have received today a brand new Panda!

My problem is : I cannot connect to my new panda with my PC. Everything was OK with my Domino (I could connect, deploy, debug, etc.)
Of course I have plugged the USB cable, and the little led nearpanda’s usb plug is lighted.
But with MFDeploy, ping does not answer…

Is there any specific driver I should install/reinstall?
Any idea?

Thanks in advance!
Mathieu


#2

Do you have latest sdk installed? Tried connecting with TeraTerm and erase current and upload latest firmware? Tried a different usb cable? Check for foregn matter in the connectors? Try a different USB port on the PC? Chucked it at the wall? :slight_smile:


#3

Is it plugged right into your PS or you are using a HUB? Try direct connection please.


#4

Does any other USB device work on the PC USB port? ie… flash drive!

Also check IC3 on the panda for getting hot, just in case you have a stray one…

Cheers Ian


#5

Have you tried the LDR/Reset combination to get it in serial mode. If it shows up as a serial device, you might try to reload the firmware.


#6

Happy new year!

I try to answer your questions one by one here:

@ William :
- I have latest SDK installed.
- I have uploaded latest firmware right now, but no change. I did not do it before because I force myself to follow the step by step tutorial (and the deployment tool should work BEFORE updating the firmware).
- I tried with other USB ports, same result

@ Gus : I don’t use any USB hub.

@ IanR : There is no other USB device excepted the mouse… and no flash drive. IC3 is cool…

@ Geir : I don’t know this LDR/Reset combination, but tried it (I guess I have to boot with both buttons pressed) => No particular change

Note that in my windows hardware panel, I can see the USBizi hardware.

Cheers
Mathieu


#7

Problem solved!
I have re-executed all the tips you gave to me, rebooted my PC, and now I can ping! thanks a lot. The only sad thing is that I will never know which tip did work…

Thank you all!


#8

Look in your assemblies list and remove FEZDomino_GHIElectronics.NETMF.FEZ and add FEZPanda_GHIElectronics.NETMF.FEZ instead :slight_smile:


#9

Oups sorry Gus, you replied to a question I just deleted in my previous message, because I found the cause…
(I know no one should modify a post, but I thought my modification occured fast enough after my original post… But Gus answers faster that light)

So yes Gus, my exception
"An unhandled exception of type ‘System.InvalidOperationException’ occurred in FEZDomino_GHIElectronics.NETMF.FEZ.dll
Additional information: FEZ Domino not detected!"
was due to references to FEZ_Domino_… instead of FEZ_Panda!!


#10

No worries… have fun with FEZ