Main Site Documentation

Connectivity problems after installing GHI Software Package v4.2 Update and performing a firmware update


#1

I’ve used a Hyrda at the default IP address without any problems for a long period of time. I needed to change the IP address so I thought it would also be a good time to update the driver/firmware. The installations worked fine and the firmware update did as well.

I’ve used FEZ_Config_v011 to change the IP address. I ping it at the new address and it responds as expected. I’m using the same code on the Hydra pre-update that I’ve been running without any problems at the default IP address for a long period of time. Pre-update, I could connect and disconnect to it with a desktop piece of software without any problems. However, now it works for a while and then the network connection drops. After this happens it doesn’t respond when I try to ping it. It just says that the request times out.

When I reset the Hydra, I can go back to pinging it without any problems. I have to have a stable network connection to the device for the application to work.

Any ideas on what might be causing the network connection to drop and what steps to take to correct it?

I’ve tried connecting through a switch and connecting direct and it behaves the same.


#2

I’ve been on 4.2. I only updated to GHI Software Package v4.2 May. 1, 2013.

I was already using .NET Micro Framework SDK 4.2 (RTM QFE2).


#3

Hi DWC, welcome to the forum

I don’t think you’ve given enough information to delve into this for you. Providing more detail like how are you using networking between the PC and Hydra, socket errors, debugging steps you’ve taken and findings you’ve made, does flashing a LED on a timer show you the CLR crashes because flashing stops, etc will all help us hypothesise, but it’s likely that you’ll need to show us code to really help here. Oh, and of course it’d help if you told us what firmware version you went from and to, so we (or you) could look at release notes and see what changes might be relevant to your situation.


#4

I shut everything down and came back to it this evening. Everything ran as expected for several hours. I was able to connect and disconnect as needed as well. I was developing code for a NI cRIO device on the same machine during the time I had the problems. That could have had a residual effect of some sort. Maybe all that was needed was a good power cycle on all machines. Thanks for the replies.