Connecting to Panda II after erase problem

Sory if my question double posts. I didn’t seem to go the first time I submitted it.

I recently decided to convert a project I’ve been working on (with the Panda II) to native ARM code due to some performance issues I was having. I had gone down the RLP road and that helped a great deal but I found that to really get the performance I was looking for on this project, I had to move more code down than I would have room for in the RLP space on the Panda II.

After digging on the forums I found that I needed to flash the board with the USBizi_ERASE.GHI firmware. I did this using USBIZI Updater.exe. The flash seemed to go OK. After that I see no signs of life from the board. I’ve tried connecting serially through a serial to TTL level converter to TX->D0 and RX->D1. I then ran flashmajic (and did the button sequence to get the boot loader) but I can’t connect. The error states that the Autobaud failed. I’ve also tried to connect with a JLink to the jtag port following the pinout from the Panda II schematic. When I try to connect using JFlash, it gives an error of no flash devices found.

So is flashing USBizi_ERASE.GHI with USBIZI Updater.exe OK to do? I couldn’t find any information saying anything to the contrary but at this point it sure seems that my board is bricked. Is there anything else I can try to get the board back? I have another on order but I really don’t want to try this on another until I know what went wrong on the first.


If I am not mistaken you need to use JTAG header to program the board. Right now you have blank MCU with nothing on it.

Thanks for the quick reply. As I mentioned, I tried to connect to the jtag with a jlink and got an error of “no flash devices found” in jflash.

I looked through this wiki and it didn’t seem that there was any mention of having to use jtag instead of serial. Am I missing something or is there another wiki that I should be looking at.


oops sorry…

The wiki I was looking at is here:

I deleted that wiki page. Once you erase your device you can no longer use it with RLP or NETMF. That wiki page said “Erase your FEZ Panda: ( ! WARNING - can’t be undone - voids warranty ! )”

Your board is now an ARM development board. You can program it using JTAG or tools from NXP, the processor manufacture but not using any tools from GHI.


That is exactly what I’m trying to do. Make it an ARM Native dev board. I understand that It won’t go back after being erased and started with that understanding. All I want to do is get native arm code on there.

The problem is that I can’t connect using JTAG. Again, I connected a jlink tool and followed the pinouts shown in the panda ii schematic to make the connection.

So, again, my question is: Did I do something wrong in the erase process that the jtag port did not become enabled?


You should be fine. Check your connections again

Thanks for the response. Just wanted to follow up…

I did get it working with the jlink on the jtag header. My physical connection was fine. The problem was that I had selected the processor as “Core ARM7” in jflash. Once I changed that setting to “Device LPC2387” I was able to connect and flash the device.