Main Site Documentation

Computer does not find my Hydra anymore


#1

Hello everyone

I’ve just received my Hydra mainboard and wanted to start.

I’ve installed the .NET Micro Framework and followed the installation instructions here: https://www.ghielectronics.com/support/netmf . Everything went fine and I reached this point: https://www.ghielectronics.com/docs/230/first-time-netmf-setup , where I needed to update my firmware. I chose the method 1 from https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra and run the code. The green light flashed and I reseted the board.

But after doing that my computer does not recognize my hydra anymore. I tried re-installing everything (including the drivers) but nothing seems to work and I am stuck. Fez Config does not find my board and neither does Visual Studio. There is a yellow exclamation mark in the device manager and it says “Unknown device”.

Can anyone help me how I can fix this problem? I’ve tried for several hours but didn’t come to a solution.

Thanks a lot in advance!


#2

Hi Stanbe, welcome to the forum.

Yellow exclamation mark is the problem, your device doesn’t have a driver for it (or the device doesn’t match what drivers you have).

Can you tell us what GHI SDK you downloaded? Was it the 2014 R1 version?

Can you open Device Manager and take screenshots of the device that doesn’t have a driver, and show us?

Personally I suggest you go back and try Method 2 to go back into bootloader mode (where you should see the “GPS Camera” device appear in Device Manager) and reapply the firmware from there. Make sure you document here for us what you see in Device Manager at each step in the instructions, so we can get a good idea what might be happening


#3

Hi Brett

I could solve the problem. I just connected the mainboard to another computer. It was able to detect the mainboard and successfully update the firmware. After finishing I connected it again to my “trouble”-computer and it could detect it successfully. So everything works now as expected and I can start hacking :slight_smile:

Thanks a lot though for your fast answer. I really appreciate it.

Cheers


#4

awesome news !

Now go make cool projects !! :slight_smile: :smiley: