Main Site Documentation

Cobra II Wifi and NRF24L01 Initialization and Configuration


#1

Hello,

I am trying to use NRF24L01 module on Cobra II wifi board via SP1 that have carried to expansion pins. I have tried many configurations for ChipEnable and ChipSelect pins. All the changed pinouts I can initialize SPI interface and NRF24L01 driver.

In all my tries I cannot read back the module RX Address using GetAddress method to verify my configuration.

You may find my configuration for the testing and the code snippet below. I will be glad if you can help me on this issue. Thanks in advance and Kind Regards.

    public class Program
    {
        static NRF24L01Plus _module = new NRF24L01Plus();
        static byte[] moduleAddress = new byte[] { 0x02, 0xCC, 0xDD, 0xEE, 0xFF };
        public static void Main()
        {
            _module.Initialize(SPI.SPI_module.SPI1, (Cpu.Pin)11, (Cpu.Pin)16, (Cpu.Pin)1);
            _module.Configure(moduleAddress, 2);

            var address = _module.GetAddress(AddressSlot.Zero, 5);

            var verify = address.ToString();

            Debug.Print(verify);
        }

    }

#2

welcome to the forum!

what is actually happening? an exception? device locks? incorrect address?


#3

Thanks for the prompt reply.

I am not receiving any exception or device lock. Only the situation I discover is the RX Address I read back is full of 0xFF or 0x00. This is also changing without any pattern.

I also want to give further information for the pins that I have used.

P0.11 - Chip Select
P0.1 - IRQ
P0.16 - Chip Enable

I have made my connections directly with wires and did not use either pull up or pull down resistors.

These are the extra information that I give further.

Thanks.


#4

Can you take a close picture of your wiring?


#5

Hi Architect,

Back and front images of my prototyping board according to your request.


#6

Did you connect grounds on the module and Cobra together?


#7

Yes. I have used Ground line and VCC (3.3V) line of Cobra for the Module.


#8

I would check the continuity between signals as well to make sure you don’t have cold solder joint in your wiring.


#9

Hi Architect,

I have checked all the solders and refreshed them. Also cleaned all the remaining fluxes between soldered pins but nothing changed.

After initialization if I try to read the address it returns full of 0xFF in all five bytes.


#10

Running out of options here. Is SPI1 wired correctly. Try SPI2.


#11

Hi Architect,

Instead of SPI2 I have tried SPI3 but nothing changed.

If I find the solution I will also send here.

Thanks for your special support.

Kind Regards.


#12

I didn’t help much, but you are welcome ! :slight_smile:


#13

AtillaBilgic, what driver/module is this you are using?