Main Site Documentation

Cobra II not seen by mfdeploy


#1

I’m hoping that this is a brain fart and easy to fix. Thank you in advance for the help.

My setup is the following:

system is a windows 7 home edition
hardware is an Asus laptop
board is the cobra II with the g120
dev environment is from the setup with visual studio express 2012

The board has been updated with the latest firmware. The windows system sees it in the devices window as a usb, but has it in the ‘other’ category.

Mfdeploy does not see it.

I’m not sure if I should revert back to the old visual studio 2010, since one of the steps to setup the environment (expert settings) doesn’t appear to be available.

I also have a question on the utility for my project of the gadget approach, since I plan on building a custom board with the g120 at its heart.


#2

HI Andre,

In Devices and Printers: Shows in the “Unspecified (1)” category as “G120”. It’s shown in the properties Hardware tab as GHI NETM Debug Interface (Name) Universal Serial Bus controllers (Type).

From FEZ Config: Loader 4.2.11.1 TinyCLR 4.2.11.2 (and I had to update the version).

The GHI directory names show v4.2.

This was a new installation. The first time I tried to run the sample program (or push to the board).

Thanks,

Dan Noble


#3

show us a device manager screen capture. That will tell you more of what is needed.


#4

Here it is.


#5

that is not Device Manager…


#6

Fine.


#7

so, looks exactly like a working driver (not what I expected BTW).

The next step is to try replacing USB cables and using a high quality one (thicker cable the better). I would also try swapping to different USB ports. Probably consider external power too (powered hub or straight into Cobra)

I would also try opening MFDeploy, and change the connection from serial to USB and back, to make sure that every time it comes up to USB it shows the correct name. If that works reliably, I’d expect you to get the same reliability in VS.


#8

Hi Brett,

The usb cable is the one that came with the board. It has a non-standard connection that goes into the board. I’ll see what I can do when I get back to my office.

I already tried putting a straight power adapter to the board, no difference.

I’ll try swapping the usb ports as you suggest.

The board doesn’t show up in mfdeploy, which was my initial problem. I’ll take a look at vs when I get back, but I was following the initial program instructions on the ghi website. It got to the deploy portion and failed.

Thanks!


#9

Hi again Dan

The board should have a standard connection - a Mini USB connection to be exact. Think 4 year old mobile phone. Maybe 6. Anyway, if you have a spare then try that. If it’s the one that GHI send out, they’re not the cheap a$$ ones that cause problems, that you can buy on ebay for $5 for 6. They often have insufficient current carrying capability to run the device.

Can you confirm if you’ve ever been able to apply a firmware to the device, and then deploy your own code ? It is possible that this may be part of the cause (a program that runs in a tight loop with no time given to the USB/Debug part of the firmware). If you think this might be related, then the way to approach that is to do a manual boot into bootloader mode, and reapply the firmware from that point - and then don’t deploy the same code :slight_smile:

In general, the issues that cause this are a corrupted driver install (fixed by uninstalling/ reinstalling the entire SDK stack), a USB3 port (been shown to cause some issues but also seen without issues in lots of places), a lack of power, and then the app problem. All reasonably well laid out over https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#10

Hi Brett,

I applied the firmware to the device because fez config said it was out of date. Here’s a picture of the current status.

I have never tried to load a program, since I never got past the detection part using mfdeploy from the instructions.

I tried swapping the usb chord to the other two ports. The laptop has two usb2 and one usb3. nothing on any of the ports.

That leaves uninstall/reinstall the sdk which I will try tonight.


#11

Can I also suggest you fill in your profile location or tell us here where you’re based, so if there’s anyone local who could assist we might be able to do an in-person test ?

So it’s great news that FezConfig can see the device. That means that at the most fundamental level there are communications going on.

When you install the SDK sequence, can you document it here for us too ? In particular, note what versions of everything you use.

Is this a Cobra2 with wifi, network, or ECO? And do you have an external power source for this, and what are the power source’s specs?

Here’s the sequence of things I would want to step through once we get everything reinstalled.

  • check FezConfig shows device is up to date.
  • Update if not the case.
  • open VS
  • new project
  • Gadgeteer type
  • select Cobra2
  • in code, just use a simple timer that pulses the debug led.
  • check deployment target can be seen in project properties.
  • deploy.

#12

Thx Brett,

I live in Tampa, FL. The board is the generic - meaning no wifi or Ethernet. My external power supply adaptor is a 19.5 v 7.7 Amp output device.

The steps I took to reinstall…

uninstalled all GHI prefixed programs.
uninstaled all microsoft .net gadgeteer and micro framework programs.
uninstalled all vs programs.

I go to
https://www.ghielectronics.com/docs/21/first-netmf-project.
It directs me to
https://www.ghielectronics.com/docs/230/first-time-netmf-setup.
It directs me to
https://www.ghielectronics.com/support.
It directs me to
https://www.ghielectronics.com/support/netmf.
I install Express2012 for windows desktop.
I install NETMF SDK 4.3 (RTM). I did a complete install.
I install NETMF and Gadgeteer Package 2014 R1.zip.
*** I did not install the USB legacy drivers ***
*** I did not uninstall the USB drivers already on the system ***

The USB drivers failed to install (see picture)

The install did say to delete previous versions, should I delete all my usb devices or just specific before rerunning the install of the drivers?


#13

I think the drivers will be the missing piece. Uninstall the GHI SDK (leave the netmf SDK 4.3 RTM installed) and then in add-remove programs try to uninstall any remaining GHI drivers. Before you attempt installing the GHI SDK again, connect your Cobra and see if the driver gets loaded - check Device Manager to see, and if you can see the device then please right click the item, select Uninstall, and then tick the “delete the driver software for this device” so it removes the files and should allow the reinstall to work. Unplug the device, go thru the install, and report your findings !

Anyone else from Tampa here and can offer an in-person helping hand ?


#14

Hi Brett,

I did the GHI SDK deletions and deleted the USB driver. It installed the usb drivers this time around. The Fez Config program sees and talks to the board. I verified that the board’s software is up-to-date.

MFDeploy still does not see it.

Is that necessary? Should I be trying to write software out to the board from visual studio?

Also, with the fact that I am going to be putting the chip on it’s own board, should I be doing the gadgeteer development or revert to the more basic development (your opinion type question)?


#15

OK, fundamentally if you’re using the right version of MFDeploy (you should check the directory you run it from - make sure you’re using the 4.3 RTM SDK location), the device should be able to be seen by ALL tools - Fez Config just uses the same method of talking to the device driver as MFDeploy does, as does VS. So we really should expect to see the device in all the tools ! The only explanation I have for this is a version issue in MFDeploy, or potentially if you have both Fez Config and MFDeploy open at once they may exclusively lock visibility out from one another (I don’t really think that’s my experience though)

Can you reapply the firmware on the device as well, just so that you get to a known-clean state of the board (even though it still matches the version you should need ). There may be some impact there we don’t know about, this just makes sure we’re not affecting what you see.


#16

I had problem when starting with Cobra2 which was almost similar: After installing current firmware, the board was visible in FEZ Config for a few seconds only, then disappeared.

After using External Power supply and reinstalling all firmware, the board worked fine. Probably the USB Power supply only was not enough to program all the firmware correct.


#17

I’ll try Brett’s suggestion that way. Thx gp685!


#18

The latest attempt did not work. Neither mfdeploy or vs sees the board.

I am going to back up a step and try on my workstation. It’s running Windows 8.1.

Brett,

Since this is a gadgeteer board, but my eventual goal is to have the chip on it’s own board, am I better off going the micro route on coding this up?

Thanks again to all for the help.


#19

@ dnoble - You can prototype using the Cobra II and then create your own board based on the G120 System on Module which is what is on the Cobra II


#20

In this context, the Cobra2 board is only a “small” Gadgeteer board; the biggest thing it exposes is all those lovely 0.1 header pins ! Unless you intend to use a lot of Gadgeteer modules in your prototype, I’d stay on the netmf path… if you’re going with Gadgeteer modules you can still use the Gadgeteer mainboard concept and drivers with your own design