Main Site Documentation

Cobra II: Error: Device not found or cannot be opened - USB:Gadgeteer


#1

Hi,

I just received my FEZ Cobra II, everything went good when updating through the G120 update tool
But now if I try to program it with a dummy project, it gives me this error:

I tried to reupdate via the tool, same success but still not able to use it in Visual Studio.

All I can find when looking for an answer is that it might not have enough power, but I just have the USB cable plugged and no module added to the board.
Any idea ?

-Thanks


#2

Do you have Cobra II in Designer window or some other board?


#3

I have a FEZ Cobra II in the designer windows and that’s all.
My board is the eco version, is that a problem ?


#4

Also might be useful:
When I plug a T35 Display on the board I get:

[quote]G120
Version 4.2.9.0
Debug: USB1
LCD: 320x240

Waiting for debug commands…[/quote]


#5

Hi,
I had the same issue. Dat from GHI told me, that it is visual studio that does not update the target device. Go on properties of your project and update the target device. See on the picture.
Roland


#6

Thanks a lot RoSchmi !
Goddamn IDEs, always messing things up :stuck_out_tongue:


#7

Going to add to this, as have just been fighting with the same problem for a couple of hours.

After making sure you have the correct .net mf version.
and your project is for .net 4.2.

If you have the same problem, that ping works, but are told that it can not find the device.
Even if the correct device is showing. Select another Transport, so that the device gets wiped, then reselect the correct transport (usb) and device.

The act of deselecting and reselecting fixed the problem for me.

Only had to do this on my cobra II, my spider appears immune to the problem.


#8

Thank you very much.


#9

I think I have the same problem, but none of that is working for me. I was getting the can’t connect error for a while. Now I get “Error: a3000000” in the output window.

I haven’t done anything with this board yet. Just pulled it out of the box and attempted to upload a blank program. Also, the firmware updater can’t seem to ping the board. It does think it can erase my program for some reason.

Does it mean anything that after pressing the reset button, LED1 is dimly lit now. It resumes in this state even after unplugging the device and plugging it back in now.

Thanks,
-Bryan J.


#10

Bryan, welcome to the forum. First up, you need to get the board and the firmware updater working so you can make sure you have the right firmware on the device. Can you please go into device manager and show us what devices are visible - I expect a driver hasn’t loaded properly. In fact, might be worth creating your own topic for this as it’s unlikely to be related to this one.


#11

Thanks Brett. I’ll start a new post with the information you mentioned.

-Bryan J.


#12

UPDATE: It turns out that the board needed a firmware update. Of course I should have started with this solution, but I thought it wasn’t connecting properly to the updater either.

For anyone else who it wasn’t obvious to, in order to update the firmware, you must power the board. Then press and hold the LDR0 and LDR1 buttons while resetting the board with the RESET button, then release the LDR0 and LDR1 buttons. After this, the firmware can be updated.

Everything seems to be working for me now. Thank you again Brett.

-Bryan J.


#13

Glad it worked for you. We are int eh process of updating the docs so hopefully this won’t be missed by future users.