Main Site Documentation

Cobra->Connect Problem


#1

Hello!
This has been a frustrating day. I had problems connecting with the G400 and could never get it working so I thought I would try the Cobra III.

It has been months since I did anything with these gadgets, but they used to work.
So, I could connect and ping the Cobra III. Then I ran my Cobra software and now it is screwed, just like this morning with the G400. I tried running a very simple program but it doesn’t work either.

I attached some jpeg files

I don’t understand what’s going on. I do remember a few weeks ago I connected to spider and it ran ok. So I tried to use the Advanced tab on FEZ Config to Update to G120 (FEZ Cobra III) but that won’t finish because it can’t connect.

If you look at the 2nd picture, you see that FEZ Confiz thinks the G120 is connected but when I try to ping it, you see the result in the last picture above.

I hope someone can help me out of this mess…

thanks.


#2

Also, I just installed the TinyClr Config program but when I run that, it says there is no device.
There is a chance to select a port but all it shows is COM1 but that is not connected to anything.
The device manager shows under Universal Serial Bus devices there is GHI NETMF Interface but there is no way to connect to it in TinyClr from what I can see.

I kind of wonder if windows 7 security or some update has now made my software not work, who knows. It seems these days if you have something working, it may not work 6 months later. It appears that when I tried to run my software, it glitched the Cobra and now it won’t communicate at all. I’m trying to go through the GHI documentation but it is slow going. Has anyone had this problem before???


#3

I also just went back to the G400 with the eval board and used TinyClr Config. It doesn’t connect either. I also moved the usb cable to the usb serial com 1 port and see that it created Port 16 on my device manager. So from the TinyClr Config program, I saw Port 16 and tried to connect but that also failed.

One interesting thing is that if I connect G400 to the usb debug port, there is no new entry in the device manager. But if I connect the Cobra, it does show the GHI NETMF Interface as mentioned above…


#4

OK, anyone here will be as confused as me.

You only need to connect the USB cable from the standard USB Mini port to your PC. Please capture a screenshot of what Device Manager shows.


#5

One thing at a time please. We all can help but we need to focus on specific issues. Pick a device and let’s start from the beginning.

First, uninstall anything and everything NETMF. Now install the latest TinyCLR. Then follow that device documentation to how to load v2 loader.


#6

Sorry Gus, I’m not sure that going to TinyCLR is the outcome he wants though. I FULLY agree that we need to do one thing at a time :slight_smile:

I suspect that these devices need to have the firmware reloaded. They have a rogue app that once you get rid of that and a consistent firmware applied should be fine.


#7

What I gathered is that he had these boards away for months and now he is getting back into the game and there maybe confusion between NETMF and TinyCLR for those who were not around for months.

Either way, I want to help.


#8

me too. We just need to know what the desired outcome is :slight_smile:


#9

Brett & Gus,

First -> thanks for trying to help me.
Second -> sorry I’ve been jumping all over the place, I thought I was somehow helping instead of being so confusing…

Anyway, let’s focus on the Cobra since this is something I have to get working again. I had done some work on this about a year ago and had a working prototype and then it got shelved until now.
Today, I got a new Cobra III board from stock (I’m not sure where the original one is but maybe I can find it, if so, I’ll try to connect to it).

I connected power and a usb cable to the usb/debug port on this new Cobra board. When I first did this, I then ran the FEZ Config program and was able to ping ok.

Next, I exited out of the FEZ config and went directly to my old saved project and set a breakpoint early in the program and then started it. It looked like it was running but it never got to the break point and
it seemed hung up and I think I killed it or maybe it just stopped, can’t remember exactly.

From this point on, I have not been able to communicate to the Cobra. I exited out of visual studio and
tried to ping from FEZ config but it doesn’t work.

I am thinking now I probably should have done some preparation to the new board (download firmware from FEZ config, etc) before trying to run my software. It’s been awhile so I think when I was able to ping the board, I just made the assumption it was ready to go.

Do you think this is the problem?

If so, then I could try something before uninstalling everything:

I think there is one more Cobra board in stock so I could get this other new board and use FEZ Config to download firmware and then see if I can run my software.
Does this make sense?

If not, then it seems from your comments above that I need to uninstall.
It’s getting very late now so I will check back in the morning…

Thanks - I appreciate your support!!


#10

Do you want NETMF or TinyCLR?

Don’t worry, your board is probably fine. You can hold the boot button so it wouldn’t run the program you loaded, and then erase the device.


#11

Agree, your board is fine. The key with pulling out a different board or a board you haven’t confirmed matches the firmware you have installed on your PC is… reflash the firmware, always.

I’ll just assume you want to keep the netmf route. Whatever SDK version you have installed is what you need to deploy to the device. Fire up Fez Config and go. Then, make sure you start a new project, copy over your code, and deploy (because that’s the easiest way to make sure your project doesn’t have some old netmf version components in it that’ll cause a clash)


#12

I think I should stay on netmf for now if I can get it to work.

I will give this a try (boot & erase & reload) as soon as I can, unfortunately today, I
am working outside the office and have no access to try it.


#13

I also always suggest starting a completely new blinky app that you know has no issues with mismatch firmware and SDK components, and making sure that this behaves properly (on restart etc), just to build confidence you have everything sorted.


#14

I finally got back into the office today and am trying to follow your instructions:

  1. I pressed the two bootloader buttons (LDR0 & LDR1) and reset the board.
  2. I see the GHI bootloader interface come up on com 18.
  3. I use a terminal program to connect to com 18 and I can get the version (1.02) and communicate.
  4. I press E to erase but it keeps coming back with
    Erase all memory! Are you Sure?
  5. I try different things such as Y or Yes or send E:Yes, etc but don’t see any documentation telling me how to
    actually get it to erase.
    So -> can you tell me how to get it to erase?

suppose I get it to erase, do I have to reload the firmware from this terminal program?
I noticed I still cannot ping from the Fez Config program…

thanks!


#15

I attached this picture. To me it makes no sense as it shows there is the GHI NETMF Interface in the
device manager and in the FEZ Config you can see the G120_G120 is there.
But if I ping, it doesn’t work and says there is no device, but wait a few seconds and you see G120_G120
again.

And as mentioned above, I can do the bootloader but the E command for erase does nothing.
Please Help when you get a chance, I am stuck!

thanks!


#16

Hello again.
Well, while waiting for an answer to previous questions, I used the terminal to
download the firmware (NETMF v4.3 SDK\Firmwares\G120\Loader.ghi)
and it seemed to transfer the file ok.

But, still cannot ping from FEZ Config.
This really is frustrating, wish someone could help…


#17

Were you able to erase before loading the firmware?

By the way, why did you decide to use NETMF vs TinyCLR?


#18

Hello Gus,

As I mentioned, I used the terminal to send the E command but it comes back with
Erase all memory! Are you Sure?

And I don’t see any documentation what to do next. It doesn’t seem to erase. I was asking above
how do I get past this question that comes back Are you Sure? I tried sending Y through the terminal
and other things but it doesn’t do anything, just comes back with BL.

The reason I’m using NETMF is because that is what my project from last year was based on.
I need to make some mods to the project and thought it should be easier. I don’t know what I would
have to do with references , etc if I go to TinyCLR.

I attached a screenshot show the terminal output and showing I sent E in the send command box.
I also tried tera term but same result…


#19

I think it is Y or Yes, case sensitive.

This is the docs for the loader but this piece of info is missing, @Dat_Tran was it Y?
http://docs.ghielectronics.com/software/tinyclr/loaders/ghi-bootloader.html


#20

yes, it was uppercase Y. You should try a different terminal program, if I remember there was some sensitivity (possibly to CRLF or LFCR order?)
http://old.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families has the link to teraterm version that GHI suggested, you might need to web search it as it’s no longer online at that link (or even changing out the WWW to OLD)