Main Site Documentation

Cobra and 7" LCD display


#1

I got a Cobra main board and a 7" LCD display yesterday. I managed to run theLED on/off program on the Cobra board. When I connect the LCD display to the cobra borad using the cable provides (of couse, power disconnected), it has stoped working the cobra board. When I disconnected LCD display, it worked again.

I used the 6V 2 A power supply, cobra board works fine without the LCD display. Can you help me please?


#2

Are you sure you connected the cable the right way not opposite?


#3

Yes. It was connected to the same side as the ribbon cable connected in the LCD panel.


#4

Does the LCD backlight lights up when you plug the power in?


#5

I re-connected agin. It is working now

Thanks…


#6

Good, and welcome to the community.


#7

Do you have any test program to test the display module?


#8

see display tutorials on this page http://tinyclr.com/support/


#9

I followed the example given and talk to the display. I also tried your example for 7 LCD display. When the power is supplied to the main board, LCD display continuously refresh with different patterns. No response from the display at all when the display program is deployed and executed. I need your help to talk to the LCD display…Please


#10

You did not load the configuration like explained in details in the display brochure/manual :slight_smile:


#11

Thanks. I spent four hours last night but I couldn’t get it to work. Today, I upgrated the firmware.

It is working now. I can see Hello World on the screen. Thanks a lot.

Do I need to deploy the LCD configuration each and every time I deploy a new program or does it stay in the memory until I deploy a new configuration?


#12

Only once and after every new firmware.


#13

Thanks… I managed to run several display programs succesfully. How I can I find when new firmware upgrade is available?


#14

Announcement on the forum, and manually check the downloads page.


#15

Thanks.


#16

GHI RSS feed


#17

Help :frowning:

I’m having a similar problem with the 7-inch display.

I successfully loaded and ran the “configuration” application suggested in the display brochure.

I then loaded and ran the “GHI_Graphical_Demo_7in” project.

It immediately goes into calibration mode. I click [SELECT]. It displays the cross-hairs, which I click on. It progressively moves the cross-hairs toward the upper left corner, but then goes into a loop where it moves a small amount, then back again, and never finishes calibration.

What am I doing wrong?


#18

It looks to me you have mixed two programs. I suggest to reload the firmware and run the configuration again.

Please find my configuration program.


#19

Thanks Sarath. I can’t find your configuration program. Could you send a link please.

I created each project as a separate application in VS.

The display “configuration” program was copied from the display brochure into the Program.cs file of a new project, and it ran successfully.

I then extracted the VS project from this zip file and ran it:

Everything ran, but the calibration program in the second program never ended.
It seemed to be in an endless loop.


#20

I have both calibration and configuration projects. Please send your email address I will email to you