Main Site Documentation

Clr_e_entry_not_found


#1

Hi I am trying to use this open source project at

http://www.skewworks.com/ftpserver/

I am using FEZ COBRA 2

ERROR: CLR_E_ENTRY_NOT_FOUND

I have the error as in the subject while I am trying to build and deploy the project. I am clueless what it means. Can anybody please help me out


#2

I resolved that but now I have this coming up

Cannot Deploy the base assembly ‘mscorlib’ or any of his satellite assemblies to device - Serila:COM4 twice. Assembly ‘mscorlib’ on the device has version 4.2.0.0 while the program is trying to deploy version 4.1.2821.0


#3

I am using netmf 4.1 and FEZ cobra 2


#4

Needs to be 4.2


#5

Hi justin, many thanks for your reply… but the website states that the netmf to be required is 4.1 is it fine if we use 4.2?


#6

I dont know why that error is coming up again, but I am seeing the same error as in the subject while trying to run


#7

I am seeing the same error as in the subject line again…

CLR_E_…


#8

You probably need to remove and re add all your references. Whn Importing old projects targeted at older versions of .NetMF you will always need to do this.


#9

I will try that and let you know…many thanks for your reply


#10

I tried that …I removed all the references and added new ones…(I added few from GHI netmf 4.1 and others from GHI netmf 4.2, i DONT KNOW IF THATS OK)…but it is still giving me the same error. What should I do?


#11

Hi Vijay,

Your device MUST run 4.2. It already has some version of 4.2 on it (one of the errors says so).

You need to make sure you install the correct firmware that your SDK comes with.

Then you need to start a new project. You must start a 4.2 project. Do NOT add references to old 4.1 framework components.

The FTP server project you had was originally written for 4.1. You must take that and translate it for 4.2. That might be simple or it might be more work. But you need to do that, it’s not going to be a case of dropping in the old code and it’ll just work, sorry.


#12

Is there any way I can push back the firmware version to less than 4.2 (Specifically 4.1.2821.0)


#13

A Cobra 2 is a new device, so is not included in any old framework version SDKs. So no, you have to use 4.2.


#14

Thanks for clarifying this Brett, it helped me a hell lot…are there any codes for ftp/http/tcp for the netmf 4.2…I look forward for your reply…


#15

Sure, just take the 4.1 code and modify it. It won’t be straight forward, but it’s not like you need to develop any logic. The network stack changed in 4.2 so that’ll be the main changes you will need, but the rest of the code besides network initialisation is unlikely to be much hassle.


#16

I am really new to this development…I think I have to identify the outdated namespaces and replace them with new ones and use their classes right ? am I on the right lines and could you kindly direct me to any documentation where I can find these changes please… Thank a lot again


#17

you’re generally on the right avenue there.

But since you’re new to the framework, I’d stay away from a complex project first up, I’d get familiar with things by making the LED flash, understand more about the way you make things work, then look at some basic networking examples or projects for Cobra2/4.2 and once you’ve got those working to prove your network connection. Then you would be better positioned to take 4.1 code and add it to a working 4.2 “core” network code.