Main Site Documentation

ChipworkX Library Issue


#1

So for some reason, when I download a solution to my ChipworkX module it ends execution before hitting Main(). This only happens when my code references Configuration.LCD.Configurations. If I remove that and any other line of code that would need access to the GHIElectronics.NETMF.Hardware library it downloads and executes fine. I’ve tried updating the CLR with the latest rev from GHI, with no change. I have verified that the library version is 4.1.5.0 according to what Device Info shows in MFDeploy.

Has anyone else had this issue?


#2

Do you have matching SDK and firmware? Sounds like a mismatch.


#3

That was my thought too, and why I uninstalled the GHI SDK, downloaded and installed the latest. Then erased and reloaded the CLR onto my board.

I just tried reloading the library reference, that fixed it. I have no idea what library it was referencing before…a little disconcerting that a reference can get hosed up like that.

Thanks for your suggestion Mike!


#4

one soon learns, when updating the sdk the references of a project need to be removed and reinserted.