Main Site Documentation

ChipworkX DevSys Tinyloader update failed


#1

hello,

i got a ChipworkX Development System (V1.5) two months ago, and now finally wanted to do first steps with it for a university project.

i started with the firmware upgrade - beginning with Tinyloader at first, follwoing all the steps in ChipworkX Development System Getting Started Rev.1.10 July 21, 2010, page 20 on.

After erasing the flash, the subsequent steps in the guide are not possible. the device is not recognized as usb device (camera device) in windows as it was stated. the device does neither react on the keypress combination (the screen remains white without any flash all the time) nor the Emergency Bootstrap access procedure.

i use win7, the ChipworkX usb x64 drivers have been successfully installed before, when i powered on the board the first time. So the device should have been ok.

i use a 1.0A@ 12V power supply.

what can i do?

regards, rene


#2

Does windows detect any device when USB cable is plugged in?


#3

hi,

there is no reaction at all, if i connect the ChipworkX DevSys via usb cable.

however, the computer has no problems with other usb devices.

regards, rene


#4

Windows should detect it and define a new COM port number.

Make sure that the small jumper on ChipworkX module is still there.

Connect ChipworkX USB directly to your computer, no USB hub. or use a powered HUB or better connect external power.


#5

There is a small jumper on the ChipworkX module. Remove the jumper and the power the board/connect usb cable. Windows must detect a CDC device


#6

hello,

it finally worked!

the point was, that the tinybootloader usb device was never notified in the windows system tray for some reason.

i took a look at the windows device manager and it actually was found as unknown device. i installed the USB Tinybooter Updater driver manually from there, and sucessfully completed the update procedure. maybe you drop a note on this in the Getting started guide.

sorry for stealing your time on this newbie problem!

thanks and regards,
rene


#7

It is good you got it working :wink:


#8

Hello, I like to update my ChipworkX V1.5 Board with the new firmware so I can use VS2010 C#.
After erasing DataFlesh and NOR Flash, by using the UP, Select and Down Buttons and wait one min.
The ChipworkX Board have now a total blank TFT display, my XP PC detect a new Com port6 and
Tera Term VT detect also the new Com port6 but with Upper-C, B or X nothing happened.
I remove also the jumper on the back of the ChipworkX Module.
Can you help me, what is wrong? Thanks a lot. Eddie

By the way I up date my FEZdomino with the SolutionVersion 4.1.3.0 it’s okay


#9

ChipworkX is different that Domino. There is no GHI loader inside so C, B or X will not do anything.

You will need SAM-BA software to upload TinyBooter as described in the user manual


#10

Okay, I run SAM-DA CDC2.9 and Com6 is ChipworkX.
Then under "Send File Name I load “TinyBooterLoader” then I update with MFW Deployment Tool
ER_FLASH and ER_CONFIG. The solutionVersion is Now: 4.1.3.0
Thanks a lot again. Eddie :smiley: