Main Site Documentation

ChipworkX Code Update Issue


#1

I just powered up a ChipworkX module to erase and update the CLR and I think I might have bricked it. MFDeploy detected it so I erased the CLR and managed code area, and then MFDeploy crapped out. That was because it was no longer able to communicate through USB to the ChipworkX module. I tried changing the Up,Down,Select pin polarity to bring it up in boot mode to no avail, my computer does not detect it as a USB device.

Again here are the steps I took in MFDeploy:

Powered up ChipworkX (Up,Down,Select floating)
Opened MFDeploy
Selected USB as the communication interface
Pinged the ChipworkX module, it responded correctly
Clicked the Erase button, it start erasing but after about 5 seconds MFDeploy crashed

Any suggestions?


#2

Follow the steps in the getting started guide to erase your board and update the tinybooter again:
http://www.ghielectronics.com/downloads/ChipworkX/ChipworkX_DevSys_Getting_Started.pdf


#3

It turned out that my USB hub was on the blink. Thanks for the suggestion Mike.

So now I am back to the issue that made me think I needed to update the CLR. I am getting a “System.Argument” exception at the line of code that sets the lcd configuration. Attached is a screenshot. This same code worked fine on the EMX, and I’ve even copied the code from the FEZ 7 inch display example without any luck.

Any suggestions?


#4

Oh you are using the 7"

First, make sure the TinyBooter and firmware are 4.1.5.1 before proceeding.

Next, on ChipworkX, there is a limited range for SyncPulse. Try 60 instead of 150 for horizontal sync pulse.