Main Site Documentation

CharDisplay Jibberish?


#1

I’m trying to write to a CharDisplay v1.0 (DLC162D VER1.0), but all I seem to get is jibberish. I’ve tried 2 different ones and get the same thing, so I’m (almost) sure it’s something I’m doing wrong and not a defective unit.

Here is my code in a timer_Tick. The Debug.Print is giving me 0.60A, but the CharDisplay gives me " .$ @ " (the @ is rotated 180 degrees).

        char_Display.Clear();
        char_Display.CursorHome();
        char_Display.PrintString(current_ACS712.Read_DC_Current().ToString("f2") + "A");
        Debug.Print(current_ACS712.Read_DC_Current().ToString("f2") + "A");

I’m using a Cerbuino Bee with no Bee. I also have the current sensor and the LED7C attached.

I downloaded and installed NETMF and GHI’s package yesterday (July 11th), so I believe everything should be current.

I’d appreciate if someone can tell me my stupid mistake, whatever it is.


#2

We had this problem a while back where a delay was needed in the driver to make it work on Cerberus. We fixed it then but maybe more delay is needed?


#3

Is there a way I can implement the appropriate delay in my code?

Just to be sure I haven’t screwed up on the versions, this is what FEZ Config printed out.

Connecting to device…Cerb-Family_Gadgeteer
Loader (TinyBooter) Version: 4.2.6.1
Firmware (TinyCLR) Version: 4.2.6.2


#4

Simply add the code of the driver then modify it, instead of using the assembly. They’re is a document that explain how to do this.


#5

Thanks, I added an input port which is throwing an exception, but the CharDisplay is now working, even after I commented out the input port. Confused, but progress I guess.


#6

Here is the thread Gus was referring to

https://www.ghielectronics.com/community/forum/topic?id=7423&page=2


#7

@ PintSize.Me - What exception are you getting? Can you show us how you are constructing the port object?


#8

The exception wasn’t related to the CharDisplay issue so I didn’t go into it, but I did get the new exception solved. It was all just confusion with referencing the Arduino pins in a Gadgeteer project.


#9

@ PintSize.Me - Glad to hear it’s working then.