Main Site Documentation

Cerbunio Bee being 'killed' off during deployment


#1

Hi,

Running Cerbunio Bee on .NET MF 4.2.100 deploying from VS2012 Ultimate.

During a day of development, with repeated successful deployments, my Cerbuino Bee suddenly stops being recognised as a valid USB device.

This has now happened with two Cerb Bee boards. I’ve attempted to reflash the boot loader, but the ST DFU Tester app failed with an error during the erase phase of the reflashing process. The device no longer boots into LDR mode.

This has happened on two boards identically now across the last two weeks.

Does anyone have any advice how to recover the boards given the LDR method no longer works and the boot loader is partially erased?

Cheers
Paul


#2

Details of the DFU error:

Error. Detailed situation:
Operation: 3
ErrorCode: 1234500A
Percent: 8
dwTag: 00000028
szDevLink: \?\usb#vid_0483&pid_df11#306633493531#{3fe809ab-fb91-4cb5-a643-69670d52366e}
wTransferSize: 2048
LastDFUStatus.bStatus: 11
LastDFUStatus.bState: 10
LastDFUStatus.iString: 0
LastDFUStatus.bwPollTimeout: 0
CurrentRequest: 10000000
CurrentNBlock: 0
CurrentLength: 5
CurrentAddress: 08000000
CurrentImageElement: 0

I have managed to get the boards to boot back to LDR mode, but this error is obtained when trying to perform an erase from the created map.

Can anyone explain the output states?


#3

I see others have tried to use the DfuSE app. I had 3.02 installed so thought I’d give that ago.

The result was that the app reported the device was in read only mode. It helpfully asked if wanted to turn that off, so I did.

After that it appeared to deploy the DFU file but it did not boot, so I tried the DFU Tester app which this time did deploy the DFU.

After using Fez_config 13 I have a booting and usable device.

I hope this simple summary helps others.

Cheers
Paul


#4

I have some custom boards that are in a state like this, never bothered to spend time on it but i try this next week to see if this solves the problem. Thanks and a +1 up front :wink: