Cerbuino SD Card - I'm Lost!

Recently bought a Cerbuino to build a home project. On of the features I wanted was the SD card.

It’s been a while since I’ve done any .Net but getting back into it (slowly). I am, at the moment, regretting buying a Cerbuino as there seems to be little support out there for it!

Anyway, I’ve been through forum and found a lot of posts on the topic of reading and writing to an SD card, but all seem to have problems. None seem to have been resolved and, of the ones I’ve tried, none seem to work. Can anybody help me with reading and writing to and from the card, ideally using the 4 bit interface.



Hey Dangerous, welcome to the forum.

4-bit interface is not used for SD cards within Fez-land; the micros in use all use a full SD card interface. So can you tell us more about what doesn’t work ? Errors?

I will also say, if you haven’t already confirmed it, can you make sure that you have updated the firmware with the same version of your SDK? There was a beta release in the last week, and while it’s Beta, it addresses a number of issues that mean it’s worth installing it and reflashing the firmware.

Here’s some Gadgeteer code (for Hydra) that I think should be a suitable test… http://www.tinyclr.com/forum/topic?id=7835&page=1#msg76889 and look through Duke’s last post. There’s a lot of things related to his sensors but the basics of the SD card usage should be what you want.

Hi Brett

So I tried the code in this post: http://www.tinyclr.com/forum/topic?id=8556&page=2#msg84904

I have three errors. First related to IO does not exist in namespace Microsoft.SPOT. The other two relate to namespace “Gadgeteer” could not be found.

I haven’t installed the Beta SDK, but have upgraded to the latest release.

Will look at the posts you’ve linked to. Asking a basic question, does the SD card socket on the Cerbuino get treated as if it’s an SD card module on other devices?



I also get similar errors with Duke’s code.


@ DangerousDave - I am not at my dev PC now so I can’t check the names, but have you added the references to the required assemblies? For example, for the IO namespace you could need to add a reference to the Microsoft.SPOT.IO.dll, not sure if that is the name, but you get the idea?

OK. Rookie mistake there. Let me go away and play and see where I get to.

Thanks both.


@ DangerousDave -

You probably have started with wrong project template.

  1. Choose the Gadgeteer template
  2. Add Cerbuino main board in the designer ( this should add required references for you )