Cerbuino Bee USB Driver


I have just been given a Cerbuino Bee for Christmas. When I first tried it on my laptop, prior to attempting to update the firmware, I ran MF Deploy and the Bee was listed under the USB Device drop-down and all appeared to work fine. However, after (I believe successfully) loading TinyBooter using STDFU Tester and pressing the reset button as per the online tutorial, the Bee was no longer listed in the USB Device drop-down menu in MF Deploy, suggesting that it was not recognised by my laptop. Thereafter, I attempted to update the USB driver without success. I subsequently tried the Bee on another computer and, having installed the USB driver when prompted after plugging the Bee in, it was successfully recognised in MF Deploy and under Device Manager. Thereafter, I updated the TinyCLR firmware on the Bee using this second computer and all seems fine.

Going back to my original laptop, the Bee is still not recognised, so I am currently thinking that I may have a USB driver issue here. When plugging in the Bee, it pops up under ‘Universal Serial Bus Controllers’ as ‘GHI NETMF Debug Interface’ and claims to be working properly. It is also worth mentioning that when I plug in my (working) Domino board to this laptop, the Domino appears under ‘Debuggable .Net Micro Framework Device’ as ‘GHI.NET Micro Framework USB Debugging Interface’, rather than under ‘Universal Serial Bus Controllers’. If I attempt to update the Bee’s driver software in Device Manager, I just get ‘Windows has determined the driver software for your device is up to date’.

Could anyone please help?

Many thanks


Which version of Windows are you using?

Are you using the latest versions of all the software from the Support page?


Try plugging your Cerbuino into a different USB portIf not, uninstall everything GHI.* and “Microsoft .NET Gadgeteer” & “Microsoft .NET Micro *” related and re-install.

1 Like

I am using Windows Vista SP2.

@ IanW - Are you making sure to ‘Create From Map’ in the STDFU before erasing and then deploying the firmware?

Dear IanLee74,

Firstly, apologies for the tardy response! I have removed then reinstalled all the software as suggested and all is now fine.

Many thanks