Cerbuino Bee power issue?

I have a Cerbuino Bee with a 1mW XBee chip antenna, RFID, and 4 relay that I am using in my garage controller. It had been working great until last week when the relay stopped triggering (couldn’t hear the click and nothing happened). I tried plugging it into my laptop thinking that either the relay had gone bad and that I would just change the code to use #2, or that there was some code issue. Oddly enough it worked fine and then I moved it back to the power source and it stopped working again. Today I had time to dig in, so plugged it back in and it worked off the laptop power in both run and debug modes, plugged it back into the power source in the garage and it didn’t trigger. The status updates always work, so the Cerb is getting power.

The problem is the Chargepod (using as a UPS for the Cerb) I had it plugged into, for some reason when it is plugged into the Chargepod the relay will not fire, but I added the mainboard debug LED to the method so I can see it is going into my method (5 lines of the method are below). When I plug into the wall adapter directly instead of the Chargepod the relay works fine. I’m open to thoughts. The Chargepod can supply plenty of power, it even will charge up my wife’s iPad.

        relays.Relay1 = true;
        relays.Relay1 = false;

Any ideas why the relay won’t fire when the Cerb is plugged into the Chargepod?