Cerbuino Bee not recognized at all

I recently got a Cerbuino Bee and I have been unable to get my computer to recognize it at all.
I’m running Windows 8 64, installed NETMF 4.2 (QFE2) and the GHI SDK.
I get absolutely nothing when I connect the board. The power LED comes on and that’s it, computer doesn’t show anything connected.

Any ideas?

Have you tried adding power, different USB cable, or powered hub?
Is it usb3?

Welcome to the community.

The most important thing you can do is tell us do you get USB device connect/disconnect noises, and show us an image from your Device Manager.

Adding power = nope
Different USB cable = nope (I can only find another mini USB cable, don’t have a regular USB cable)
I don’t have a powered hub.
I am not plugging it into a USB3 port.

My computer makes no sound when connecting or disconnecting it.

I have a Netduino as well and it shows up fine when I connect it.

This is my Device Manager with the board connected and with external power

The only two explanations I have for that is that the board is getting power (LED comes on) but the program / processor isn’t able to start; or your board doesn’t have a firmware on it at all. Can you examine the board and look for anything that looks suspicious like chips not soldered on, or bridges of solder around the data pins on the USB connector or processor pins? I then think the best thing to do is to contact GHI or whoever you bought this from and ask for an RMA, if you don’t get a device detected at all, there’s not much you can do.

I would however really try to find a different cable to use - the one you use for netduino should do (assuming plug compatibility?) as that’s about the only other thing that can be suspect.

Just be 100% sure, is it possible to plug it in a different pc?

I got similar behavior from mine, Win 8 doesn’t want to tell you about it if doesnt know what to do with it, mine needed Tiny Booter updating.

you will need to short out the 2 large copper pin holes With “LDR” written next to them when powering it up and view it in DFU tester, windows wont show it, then follow the instructions above.


Sorry it’s taken a while to respond and thank you for all the helpful input.
I tried connecting it to another computer (Win 8 as well) and still get nothing. No sound / reaction from the computer whatsoever.
I’ve tried using a wire to connect the LDR holes as well on both computers and nothing.

Guess I’ll RMA and hope for a good one.