Cerbuino Bee Firmware Failure

I just bought 2 Cerbuino Bees. I’m trying to update the firmware on both. The first one went smooth and completed successfully. The second one is giving me a “failed to deploy” error (see image). I tried with USB power and external power, I tried rebooting my PC. I tried using MFDeploy 4.1 instead of 4.2 but 4.1 doesn’t see the cerbuino on the USB port (4.2 does). Here are the steps I’m using:

open DFUTester
boot cerbuino in DFU mode and verify DFU mode in DFUTester
on protocol tab, click “create from map”, select “erase”, click “GO” (completed successfully)
Click “load DFU file”, select “download”, click “GO” (completed successfully)
close DFUTester, and reset cerbuino
open MFDeploy 4.2, select USB "cerb_family_gadgeteer"
load image config and firmware
click deploy

Any ideas what could be the problem?

I just tried re-installing NETMF 4.2 and the GHI SDK. That didn’t work. I also tried it on a second computer. I’m convinced it’s a hardware issue. I’ll try to get an RMA and have another one sent to me.