Main Site Documentation

Cerbuino and the MaxO module problems


#1

Hey there.

I have a Cerbuino Bee and a MaxO module connected to Socket 1. Done through the designer i VS2010.

I can compile your sample OK but when I try to read or write nada happens:-( No voltage is detectable when outputing nor can I see anything but straight 000’s when I apply ground to a port.

Does anyone have a clue as to what I am doing wrong?

Cheers from Martin


#2

Welcome to the forum!

What sample are you trying?


#3

Hello and thanks.

I am running this code:

using System;
using System.Collections;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Presentation;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Touch;

using Gadgeteer.Networking;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;
using Gadgeteer.Modules.GHIElectronics;

namespace Trying_out_MaxO
{
public partial class Program
{
GT.Timer timer = new GT.Timer(200);

    void ProgramStarted()
    {
        Debug.Print("Program Started");
        maxO.NumBoards = 1;
        
        timer.Tick += new GT.Timer.TickEventHandler(timer_Tick);
        timer.Start();
        
    }

    void timer_Tick(GT.Timer timer)
    {
        //maxO.WritePin(1, 1, true);
        byte[] arr = new byte[4];
       
        arr = maxO.Read();
        Debug.Print(arr[0].ToString()+arr[1].ToString()+arr[2].ToString());
    }
}

}


#4

Ok. So what did you connect to the MaxO and what pins?


#5

A Cerbuino Bee socket 1 which is a PSUY port. Anyway the designer will not let me connect the MaxO to any other port.


#6

I mean what did you connect to MaxO pins (SV1 1- 8, SV2 etc.). What are you trying to read?


#7

Ah sorry:-) I have tried to connect ground but also 3.3v. Output I measured with a voltmeter.


#8

Ok. When you read a shift register you will read the state you have written to it before. You can’t use it as input. If you write something first, then you should read back the same value. You read 000 because you didn’t write anything.

From the description of the module:


#9

Ooops:-) Of course, but still I did not get any voltage when I tried:
maxO.WritePin(1, 1, true);

I suppose that I should be able to read 3.3volt at port 1 then?


#10

Pin 1 would be the second pin on the board. Pins are numbered from 0 to 31.


#11

You know what? I think I need to go back and try again:-) :wink:

Thanks for the info!


#12

No problem :slight_smile: and you are welcome!