Main Site Documentation

Cerberus socket confusion 4.3.5?


#1

Hmm, I had code initialising a hall sensor (Dominiks) in socket 5, working fine in 4.3.3.

Now, the same code in 4.3.5 is having a system.argumentexception on that socket.

Looking carefully at the image of my Cerberus 1.1 and the Cerberus in the documentation the letters on each socket are quite different…

When the code is deployed it states “Cerberus mainboard 1.2” which is maybe the culprit…?

What has changed in the latest R4 SDK?


#2

@ njbuch - Can you post some code and any exception message and stack trace? The mainboard version string was not updated when we released a new version of the hardware, it is fixed for the next release.


#3

Hello!

I think I might experience a related or the same problem:

I have a FEZ Cerbot 1.3.

I can connect an accelerometer (G248) to socket 1 and 2.

However, if I connect a gyro (I have two brand new of these and tried both of them) alone or with other modules to socket 1 or 2 (which are the sockets indicated as valid choices by the designer view in VS) the is an Exception thrown (despite having no own code accessing the gyro at all - just the constructor call is enough).

Details:

System.Exception

Message is "Exception was thrown: System.Exception"
No inner exception.

It is thrown by

Gadgeteer.dll!Gadgeteer.SocketInterfaces.NativeInterruptInput.NativeInterruptInput(Gadgeteer.Socket socket, Gadgeteer.Socket.Pin pin, Gadgeteer.SocketInterfaces.GlitchFilterMode glitchFilterMode, Gadgeteer.SocketInterfaces.ResistorMode resistorMode, Gadgeteer.SocketInterfaces.InterruptMode interruptMode, Gadgeteer.Modules.Module module, Microsoft.SPOT.Hardware.Cpu.Pin cpuPin)

… in the Gyro-constructor in the Gadgeteer InitalizeModules in Main.

The Version of the Cerberus board reports as 1.2 in VS 2012.
(I don’t know of course, if the Cerbot version should be the same.)

I described my setup/config in this post:
https://www.ghielectronics.com/community/forum/topic?id=16999&page=1#msg169322

Thanks a lot!
Frank


#4

… and one addendum to my last post:

Manually trying to create an instance of the Gyro class (with or without a physical device connected) always leads to an exception with a message explaining, that the socket must support type “I” but doesn’t.

I don’t know if this is correct, because I am a beginner.

But I now also tried to create an instance of the Gyro class without a physical device connected to the sockets 1 and 2. For me the exception looks just the same as if the gyro were connected.

Do I have a Gyro/drive related problem here?
I.e.: Should I better start a new thread for this problem?

Greetings!
Frank


#5

@ F. Laskowski - You mention that you are using the FEZ Cerbot but that the designer shows sockets 1 and 2 as valid choices for the Gyro. Are you by any chance using the FEZ Cerberus mainboard in the designer? Because the FEZ Cerbot is not supported in the designer anymore.


#6

@ john - What kind of code are best to suit your analysis?


#7

@ njbuch - What do you mean?


#8

I have the project, but I am not sure that is what you want. I can send an email with a project that does not work altough all specs tell me that it should…


#9

@ njbuch - Sorry about that, I didn’t see your original post when I was replying. Just a minimal project that reliably reproduces the error is all I need. The source of the hall sensor would help too.