Main Site Documentation

Cerberus firmware update


#1

Just updated another Cerberus without problems, but this one are not willing to work with me. Followed the instructions on the Cerberus firmware update closely, but it returns an error after Erase->Go in STDFU Tester program.

Any clue as to what the problem is?

Error. Detailed situation:
Operation:                   3
ErrorCode:                   1234500A
Percent:                     8
dwTag:                       0000002B
szDevLink:                   \\?\usb#vid_0483&pid_df11#345c374f3231#{3fe809ab-fb91-4cb5-a643-69670d52366e}
wTransferSize:               2048
LastDFUStatus.bStatus:       11
LastDFUStatus.bState:        10
LastDFUStatus.iString:       0
LastDFUStatus.bwPollTimeout: 0
CurrentRequest:              10000000
CurrentNBlock:               0
CurrentLength:               5
CurrentAddress:              08000000
CurrentImageElement:         0


#2

@ njbuch - Can you show a screenshot of the error as it appears in the application that you are using to flash the firmware.


#3

I had the same problem.
https://www.ghielectronics.com/community/forum/topic?id=14783&page=1


#4

Tried some of the stuff in Sinans link, no luck. Strange…

@ Aron - here is the screenshot, the text below in the window is copied in full in the original post.


#5

@ njbuch - Is this only happening on one board or all of them? Have you tried different ports? Perhaps a different computer?


#6

@ Aron - Only this board. Updated another Cerberus 1 week ago on same machine. Have tried other ports and 1 other machine. This board is working fine without the tinybooter update it seems, and I have deployed new code to it, and updated tinyclr according to 2014R1 package.

Where should I look for problems you think?


#7

Let me summarize what I think you are saying:

  1. you tried to update the loader (TinyBooter) on a Cerb (call it CERB-A) and it failed.
  2. a week ago you successfully updated the loader (TinyBooter) on another Cerb (call it CERB-B)
  3. with CERB-A you tried, unsuccessfully, to update from two different USB ports and a different computer.
  4. Even though CERB-A has errors with STDFU Tester, you find you can successfully deploy apps and update tinyCLR.

For CERB-A (the failing card), what operating system was loaded on both the computers you tested.?


#8

Sorry if I am unclear. All points Jeff stated are correct.

For both CERB-A I have tried on two different machinces, both running windows 8.1 64-bit. CERB-B was successfully updated with one of these machines.

Maybe I should try updating CERB-B again, and see if the machines has been messed up, or its the board (which is the only thing that comes to my mind…).

Thanks for looking into this.


#9

Is this maybe a power level problem? I have more success these days with one of these ‘dual power USB’ cables.

It solved at least the problem that I needed to reconnect the board every second upload attempt. I can now upload my code numerous times without hardware errors.

From the sellers page:

It seems to improve my setup but I haven’t tested it thoroughly… just an idea.


#10

@ njbuch - did you fix this problem?


#11

@ Jeff - The two Cerberus boards that needs the update are in operation, and I didnt succeed in the available window of opportunity. I will of course let you know as soon as I get to them again.

Thanks for asking :slight_smile:


#12

OK, the Cerberus board returned, and I want to update to newest firmware.

Mission 1 is to erase the current firmware. This is the status:

PC: Win8.1 and Win7 32bit
Instructions from https://www.ghielectronics.com/docs/55/loader-tinybooter-update-fez-cerberus followed best possible.

FEZ Config sees it nicely and updates to 4.3.3 without problems.

It ends in the same error as previously posted 5 months ago.

Tried:

  1. Another USB cable
  2. Powered USB-DP
  3. Another USB-DP
  4. Two different PC’s
  5. Another Gadgeteer Cable between Cerberus and USB-DP

Everything is like 5 months ago. What can I do?


#13

Update: Just updated a Cerbuino Bee and another Cerberus with newest firmware using the same rig.

I guess that Cerb is just having an issue. Should I ditch it?