Main Site Documentation

Cerberus doesn't respond


#1

My mainboard can’t more be detected when plugged !

LED are as usual.

I can’t access it neither in BOOT mode.

What can I do ?

What I’ve tried: change pc, change usb cable, add power source (with dp module). :wall:


#2

I suggest you go through the troubleshooting guide and let us know what you find please, found on the support page.


#3

Things are not so bad …

I finally can start in BOOT mode. So I reload the loader.
I’ve add an hub.

But CLR seems to be unreliable: lots of deconnections, can’t work with VS.
With Fez Config, it detects card one time, another time it can’t.


#4

Any chance you had some updates recently? I had some problems like that at one point with the Hydra boards and it was the version of the USB driver that was being used.


#5

what operating system? USB2 or USB3?


#6

On my surface,i’ve only one usb 3 and I never could do it works.
On my pc, I’ve only usb2 port. This is the one I use to develop.

My OS is W7 x64 pro.


#7

Of the cables changed, have you tried to change the gray Gadgeteer cable?


#8

Cerberus is back !!!

Why ? I don’t really understand. With Dfuse I reloaded bootloader few times, and with fez config, I reloaded tinyclr. Just one thing that seems to be buggy is the reboot clr. When I do that one time three I have to unplugged usb and power source wait a little and connect back.

One thing, I should have mention perhaps is I use netmf 4.3 with 2014-R3 beta.

I’ve tried to change grey cable, but it didn’t change anything.


#9

Cerberus is gone away …

I have a serial-usb module, I don’t know if I can use it with flash method ?


#10

Cerberus seems to be definitively dead :’(

No BOOT access. No STM in DFU detect by system. When I press boot switch before plugging Cerberus mainboard and release it after plugging, it says it can’t recognised device (Capture 2): USB\UNKNOW in device id (Capture 1).

Drivers seems to be ok (Capture 3). check cable one, two, … ten times !

What can I do ?


#11

It’s not loaded the driver as shown in your first capture (hence the ‘Unknown Device’


#12

Hello,

Thanks for give an eye at my problem.

I have try to force driver (Capture 4) (so driver is correctly installed, isn’t it ?).
I have an error with code 10 (capture 5 & 6).

I always has USB\unknown (Capture 7)…


#13

Cerberus is perhaps not totally dead …

With Serial-Usb module on socket 6, and USB-DP on 1 for power, I can read and write on flash memory with flash loader demonstrator from STM.

So I can put loader (extract with dfu file manager to s19 format) and try to put firmware and config too (hex file are s19 file instead).

But always usb\unknown device … :’( It could be driver, but I don’t understand which step I could have forget. I’m on W7 - 64bits and after some reinstallation of SDK I am now with 2014 R1 SDK.

I’ll continue investigations tomorrow. If someone could send me a total image (in s19 file) from a working Cerberus, I could be certain that the cause is driver and not the firmware.