Main Site Documentation

Cerberus dead?


#1

First time using this particular cerberus. So, I am going through the DFU stuff you have to do up front. But, the cerberus is not recognized over USB. It always comes up as “unknown device” on Windows 7 x64. I was able to update my Cerbuinos a few weeks ago from this same machine.

The USB Client SP 1.2 is the only thing plugged into it. I have it in socket 8. The red light on the board is lit, so it is getting power. The board is plugged into the same USB socket on a powered hub that I use for all my Gadgeteer work. I’ve tried two different gadgeteer cables.

I’ve uninstalled the “Unknown Device” from the Device Manager, but when redetected, it comes up as an unknown device with an error. I get the same thing whether I jump the boot pads with a wire or not.

In case it was a problem with the boot pads, I just now soldered a two pin header to them and jumped while plugging in. Still no go.

Is the cerberus DOA, or is there some mojo I can apply here?

Pete


#2

Actually, I may have found the issues, as I see at least two solder bridges on this chip. Now to clean these off and see if that fixes it.

Pete


#3

Some pads are actually connected right under the chip, which will cause those bridges usually. It could be real short but I would check first to see if those pads are connected or not.

Boards are programmed before they are shipped so it would be very strange to see this, if there is a short.


#4

Yeah. That didn’t fix it. The board still takes a bit to show up, and then comes up as unknown device.

Pete


#5

try a different USB Cable … and a different USB Port …

this happened to me when i had a spider plugged into a USB and i swapped it with Cerberus, and it didn’t work but when i moved the Cerberus to a another USB port it worked… so it’s a rule here if want to swap boards i swap USB ports as well.

cheers.


#6

Thanks Jay Jay

Different hub, different cable, same result.

Pete


#7

Also unplug all other gizmos from USB. I have an FTDI cable that will block FEZs if I try to use them while it’s plugged in.


#8

Thanks, but Spider and Cerbuino work from the same cable on that same hub.

I’ll try tomorrow on a different PC if I get a chance.

Pete


#9

Pete, I ran in to this. Completely baffling. Works fine on one PC, not on the other. Both running Win 8. All I get after a delay is “USB Device not recognized”. I assume you got yours working (old unconcluded post).


#10

@ neoscoob - this may help https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#11

RESOLVED.

TinyBooter was old. I updated to the current (4.2.5.0) and USB drivers suddenly recognized on all my PC’s running SDK v4.2.

This was not covered in the Troubleshooting doc, btw. Perhaps add a section about updating TinyBooter when devices are not recognized. I had a similar issue and resolution on two boards with old loaders: Spider and Cerberus.

This should be marked as the “chosen answer”, FYI.

Thanks!


#12

i’ve added a note in a couple of the docs regards very old firmware and unresponsive or uncommunicative devices… thanks!


#13

Glad you got it resolved. I don’t recall that I ever got mine working, but I haven’t had time to do anything with NETMF in a while. You know how it is leading up to an OS release :slight_smile:

Pete


#14

LOL. ah Pete, don’t remind me. :slight_smile: Besides, don’t you know tiny OS’s are cooler than big ones?

If I had stayed at MS, I’d have liked to keep working with Colin Miller + cloud.