Main Site Documentation

Cerb40 brick


#1

Hi,

I’ve had a stuppid idea to put Reboot() method just after the board starts. The result is that the board resets itself every few seconds. I tried use DeFuse to erase the Cerb40 but unfortunately I got a message in device manager that the device can not start and yellow trinagle is showing. The MF Deploy sees the Cerb40 but it disappears very fast and can not do anything.

Do you have any idea how I can fix the problem? Or maybe my Cerb40 is a junk now :frowning:

P.S.
I have STM32F4 Discovery board as well. Is it possible to use the SWD to erase the Cerb40?


#2

@ Sylwester - Did you following the instruction for putting the device into TinyBooter mode?

https://www.ghielectronics.com/docs/55/firmware-update-fez-cerberus

You might have to reinstall the firmware.

I have not updated a Cerberus based device yet, so I am sure exactly what has to be done.

Oh, if you bricked the Cerb40 you would be the first. You will recover.


#3

Maybe I described not clear but standard upload firmware doesn’t works.


#4

If you boot it into the bootloader mode I dont think it runs any code. Then you can erase it in DFuse, then re flash the firmware and you should be back to a good status.


#5

I tried use DEfuse but the device manager shows that the device is unknown. Previously I uploaded firmware without any issues.


#6

I would try different USB port or/and another PC.


#7

I reinstalled DFuse utility, changed USB port and still message device is not recognition. installed the DFuse on other PC and the same results. The Windows can not recognise the device.

I also tried to use STM32 ST-Link with SWD programmer. When I try to erase the chip, I get the message the the memory is protected and can not be erased or modified.


#8

Finally, I erased the Cerb40 using the STM ST-Link and SWD programmer.