Main Site Documentation

Cerb freeze with ENC28 and N18


#1

Hi everyone!

Quick question. I’m trying to spin up an app on my Cerberus with both the N18 Display and ENC28 Network modules. If I use one or the other module in my app, everything is fine. If I try to use them both at the same time, then Cerberus freezes. If I un-plug the ENC28 from the network, then the app works. In other words, it only freezes when both modules are active. I see a note on the ENC28 page that suggests its power hungry. Could I be running into a power problem? I’m using the USB Client SP Module to power my rig.

Thanks


#2

If you have DP module I would try that first, and I would power it externally.


#3

Power is a possibility. We always recommend using a powered HUB or power pack with DP module.

Do you have access to a powered hub?


#4

I tried my DP module tonight; got excited because my app started running. But after a while, it hung again. Unplugged it from the wall and re-plugged it in and got fuzz on my N18. Tried again and got more fuzz. Walked away, came back in 10 minutes and still got fuzz. Unplugged the network cable, powered it on and it started running. Then, plugged the network cable in and it ran for a while (40-60 seconds) and froze again.

It’s hard for me to say what’s going on now. When it was hanging earlier today, I had a debugger attached, but nothing was captured at the time of the hang - no exception.

Anything else obvious I could be missing? The N18 uses SPI; does the ENC28? Are they compatible? I’ve been initializing the N18, passing in a value of 4000. Could that be a problem for the ENC28?

Thanks


#5

I think I know what the problem is. Let me check.


#6

Need a code sample to test?


#7

Hi Gus,

Did you find anything?


#8

We didn’t get to it, sorry but we will do this week.

What do I need to repro this? Maybe just refresh the N18 display while pinging the device over the network?


#9

Sorry for the delay… I’ve been traveling. Yes. I think that should be sufficient. My app is a bit complicated. I reset the display, initialize it and turn the backlight on. Then, I get the default ip address and use it to start a web server. (my cerb is set up to use dhcp.) Then, I paint the screen. If I run a ping -t against my cerb, it pings for a while. But eventually the replies stop. If you have any suggestions, I can try them tonight.

Thanks


#10

We sound the problem and it is fixed. Next release should be in few weeks.


#11

Yes

Replied to the other post

Updated wiki known issues


#12

Any workaround possible?