Main Site Documentation

Cellular Radio Module Basics


#1

Hello,

I am just starting to work with the Cellular Radio Module: https://www.ghielectronics.com/docs/63/cellular-radio-module

on a FEZCerbuinoBee: https://www.ghielectronics.com/catalog/product/351 With .netfm 4.2

I’m using an H2Owireless SIM Card.

I’ve loaded the drivers from here:

But i’m not set on using them. I could also use the drivers here:
http://www.gadgeteering.net/module/seeed-cellular-radio

When I run the demo script here:https://tcpcellularradio.codeplex.com/documentation
and
When I run the demo script here: https://www.ghielectronics.com/community/forum/topic?id=14934

The module hangs after it gets the IMEI number. Is this because my SIM card does not work or is it because of the module? I’m also asking this question at the code share website.

What are some recommended good SIM Cards?

Thanks,
~Shane


#2

An update on this:

Verizion does not allow non-verizion devices on their network (per the sales lady at the Verizion store). I’m going to check with AT&T today to see if I can get a SIM Card. I think the failure is largely due to the SIM Card provider at this point.


#3

@ shanekirkbride - I have heard similar things in the AT&T contracts. I would recommend using a SIM provider that generally deals with prototype devices.


#4

So I checked with the clerk at AT&T and brought the module in with me. He said it wouldn’t be a problem. I asked if the AT&T network defaulted to a 2G network for this device and he said it would. (I moved foward with the purchase assuming he was telling the truth…lol) Now I have 2 SIM cards. They both produce the same behavior. There are a few setup scripts out there. But they both take the radio through the power on sequence but my application gets stuck at

 
It is stuck after it registers the IMEI
I've done a lot of googling and I can't seem to figure out why this is occurring. Has anyone else ever experienced this issue?

I looked at the logic in the library and it indicates that it should return 'true' when it finds the IMEI...but it does not do this...any thoughts?

Thanks,
~Shane

#5

Ok…I read this thread a few times:

https://www.ghielectronics.com/community/forum/topic?id=12072&page=1#msg122939

and found that the default AT&T PIN is 1111. So I added that in the appropriate place and the code in the thread above works just fine :slight_smile: this is with the default GHI software/configuration. I now get text messages at $0.20 a text that read “CellTest message” YES!!! happy day!!! I think the ultimate issue was the PIN.

Now I need to figure out how to set the pin in this package: https://tcpcellularradio.codeplex.com/

Any ideas?

Thanks,
~Shane


#6

Why not use AT commands to disable the PIN after you have done AT commands to enter it?


#7

Hi Dave,

I have to ask what maybe the obvious here: what is the AT command instruction set to disable the SIM PIN? I’ve looked in the AT Command reference and it was not immediately apparent in the CPIN section.

I’m guessing it would be some sort of ‘set’ SIM PIN command…
Thanks,
~Shane


#8

You would have to use:

http://www.hughes.com/AT_Command_Reference.html#AT_plusCLCK

+CLCK to disable PIN, and you need the PIN to do this.


#9

Thanks David! I’ll try this when I get home…

FYI to the rest of the world here is a discussion on the H2O wireless SIM PIN:

Thanks,
~Shane