Ceberus not recognized by OS

Hello,

my recently arrived Cerberus is no longer recognized by my Windows 7 :frowning:

It was originally recognized by the OS. Having uninstalled everything GHI and Micro Framework, I installed the full Micro Framework and GHI 4.2 package as available from the support page. As I plugged the unit in, the “USB Fez Cerberus” pop-op in the lower right corner came to. The unit was recognized by MSDeploy.exe and I could ping it.

However I could not deploy programs to it - I always got a “mscorlib version is 4.1 on your device but you’re trying to deploy a 4.2” error message. So I experimented with changing the framework to 4.1, only to get an opposite “mscorlib version is 4.2 on your device but you’re trying to deploy a 4.1” message. Frustrating. So I set out to update the firmware, as described on this page:

I installed the DfuSe_Demo_V3.0.2_Setup.exe. I set the BOOT pin high by sticking a paper-clip through the holes, similar to a piece of wire.

But when I plug the USB cable in, the unit is now no longer recognized. No lower-right corner USB notification. MSDeploy.exe cannot see the unit either, neither can the STDFU tester. And where before a green led lit up the board, now there’s but the sole red power led…

How can I bring my Cerberus back to life…? I tried different USB ports and a different PC - no luck.

:frowning:

It’s back … I’m happy.

I plugged in a Fez Spider which recognized fine -

  • and then I thought ‘what the heck’ and gave the Cerberus another try - and it’s back online! :slight_smile:

I’m ready to put my hand on the bible in that the Cerberus did not work - even tried it in a different PC - before I plugged the Spider in(!)

I can’t mark my own post as the answer to a technical question, would someone please write a Hello-World post I can mark as answer? Thanks.


[WebMethod]
    public string HelloWorld() {
        return "Hello World";
    }

:slight_smile:

… And a WebMethod, even :smiley:

@ harleydk - well it was the quickest way since i was technically doing my day job and i had a web app open…