Main Site Documentation

CDC with debugging Windows 7 driver install


#1

Hey guys

Ive been using the cdc with debugging on windows xp and it works fine but i cant get the device to be recognized on windows 7. I tried updating the usbizi driver from a hard disc and pointing it to the driver folder but that didnt work. I reflashed the fw and ran an LED blinking app and that works. Any one got a fix?

Thanks

-Phillip


#2

Welcome to the forum

did you install this:

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip


#3

I tried. I tried right clicking the inf files (GHI_NETMF_Interface.inf and CDC_Driver.inf) and clicking Install but i get a message saying the inf files do not support that method of installation. Is there another way to install it?

In XP i was able to point windows to the folder when the device was plugged in but 7 seems to be different


#4

In Windows 7 you have to go into Device Manager, find the board, right click on it and select properties. Then look for the tab that has ‘Update driver’ on it and click there. That will let you point to the driver to use. I’m not sure if the new installer package that GHI uses installs the CDC w/debugging or not but if it does that would be the easiest way to go.


#5

That worked. Thanks Jeff!


#6

one more thing

Is it possible to instal the CDC+Debug driver without installing the .NETMF and SDK? Or does it need everything?

I will be distributing boards to various people and it would be easier if they didnt have to go through the entire instal procedure, even if it is pretty straightforward.


#7

Hi guys

I’m trying to get working the sample for “USB Debugging with Virtual COM Channel” from http://wiki.tinyclr.com/index.php?title=USB_Client

However I’m stuck on line :


// Start CDC
USBC_CDC cdc = USBClientController.StandardDevices.StartCDC_WithDebugging();

I did as described above (Update driver, pointing to the directory where I extracted the files from the listed ZIP file) but no luck : Windows says it did not found any suitable driver.
the device has ID : USB\Vid_1b9f&Pid_f003&Rev_0100 which does match the ID found in the INF file.
However still no luck.
I am running with administrator rights on Seven Home Premium Edition 64-bit.

Any idea ?

Thanks


#8

Hello,

Any idea why I am unable to load the CDC driver on my Win7 ?

Thanks in advance.


#9

There are 2 drivers, one for CDC and fro CDC with debugging. The documentation page has the correct link to the driver.


#10

Gus

I downloaded the driver from :
http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip
This is the link given both in this thread and in the wiki page about “USB Debugging with Virtual COM Channel”.
Isn’t it the right one ?

When proceeding with PeripheralManager -> Unknown Device -> Update Driver and pointing to the directory where I have unzipped the above file, Windows reply that it can’t find any suitable driver.
As I said earlier, it should be the right driver as I find the same VID/PID in the Unknow Device details than in the INF file.

I have tried to delete de device and refresh without any success.


#11

Have you tried programming your fez with a non cdc program to make sure that still works?


#12

Yes, my FEZ is still working.
Played with it the whole week-end

It is just the above driver which can’t be installed.

Should this driver replace a standard one ? Version number conflict ?
I bet no, otherwise the device would not appears as unknown in the device manager.

:frowning:


#13

CDC with/debug just appears to not work now, at least with Win7-64. I have an application that uses this and now it is not working (I have used it previously A LOT). When I deploy for the first time I can get to where you have to hit “Debug->Break all” but then VS locks up. A COM port never appears in Device Manager either. Since this a custom made board I don’t have access to set the mode to use serial debug.

I’ll try the sample code with a Panda II next to see if it just an issue between new firmware and my code.


#14

It is my hardware, strange. Will start a new thread on the subject.


#15

Hi Guys

back on that topic.
I still haven’t been able to use CDC.

I have deployed on my Panda II the “CDC Virtual COM” example, adding some led blinking to debug visually.
I have connected MOD pin to ground but have not connected anything to COM1. I don’t expect to do any debugging for now.

A CDC VCOM device appears in the device manager list with VID 1B9F and PID F001.

I tried to install the CDC driver at “http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip” which does not work naturally as this is for VID 1B9F but PID F003 !

Drivers in the “\Program Files” directories (wether x86 or x64) are for PID 0102 and 0104.

So why can’t I find the right driver ?

Thanks


EDIT : If I use the CDC with debugging example, the device that comes up in Device Manager has PID F003
But still I can’t install the CDC driver in that case
Is that because the INF file refers to USB\Vid_1B9F&Pid_F003&MI_01
And my device says USB\Vid_1B9F&Pid_F003 or USB\Vid_1B9F&Pid_F003&REV_0100


EDIT 2: I have now bricked my Panda II

I have deployed the sample code for CDC + Debugging, and I can connect anymore to the device.

I try to use the GHI Updater to reflash but no way as the device remaine “Unknwn” in device manager.

Help !!! :’(


#16

Ok, this happed o me a while ago. Unistall the drivers by device manager. Then reinstall the drivers. You may need this part but I am no sure. http://www.ghielectronics.com/catalog/product/266


#17

USB to serial ?
What for ?

I have been able to unbrick the PandaII by installing everything on an XP netbook.

And now it’s back ok on my WIn7 except for the CDC driver…

Grrrrrrr


#18

I can have the CDC + Debugging sample running on my XP netbook, drivers are installed correctly.

But on my Win7 still no luck.

By the way, if I connect MOD to GND and in the code start CDC without debugging, code seems to be stuck (not thyat I have nothing connected to the FEZ Panda II serial port).