CDC VCOM driver

It took a bit of searching to find the CDC VCOM driver. How about having it on the download page?

+1

But this will only confuse new users who do not know what this driver is for

I think a short description will solve that issue. “Use only if you want a v-comm port over the debbuger channel…” or something. I think trying to find it confused me.

I can’t see the problem with installing an extra driver on my system. If its never used it’s only a small file on my disk.

Old thread this is, but help I need.

I’m using a Domino with the serial shield for debug. I’ve successfully loaded the code for the virtual Com port “Hello World” described in section 28.5 “CDC-Virtual Serial” of the Beginners guide to NETMF.pdf. When I plug in the Domino USB client cable Windows Vista doesn’t find the CDC VCOM driver even after pointing to the GHI USB CDC Drivers folder.

Vista is telling me it’s looking for a driver for a device with Hardware Id: USB\VID_1B9F&PID_F001&REV_0100.

The Ids listed in the GHI .inf file are:

[GHI]
%CDC%=DDInstall, USB\Vid_1B9F&Pid_F003&MI_01

[GHI.NTamd64]
%CDC%=DDInstall, USB\Vid_1B9F&Pid_F003&MI_01

Where is the correct driver. All I really need to do is to be able to test for a USB cable plug in, and then allow a user to do things like set the time through the virtual serial port and access the SD files. I have the SD part working and am trying to use the CDC virtual port example code as a template to get started on getting user input

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/GHI_NETMF_Interface_with_CDC.zip

I think this is what you need.

Cheers Ian

Thanks for the quick reply IanR. Unfortunately I already have that download unzipped and in my GHI drivers folder - still doesn’t recognize the driver. I even tried redoing it

I believe the problem must be related to Vista seeing a different hardware ID than what is in the drivers in “GHI_NETMF_Interface_with_CDC”

What version of the SDK are you using. They might have updated the driver when 4.1.3.0 came out.

Cheers Ian

Thanks for getting back to me. Indeed I am using 4.1.3.0 - here’s the text from the release notes file:

• USBizi (FEZ Mini, FEZ Domino, FEZ Rhino, FEZ Panda) V 4.1.3.0
• EMX (FEZ Cobra) V 4.1.3.0, TinyBooter V 4.1.3.0
• ChipworkX V 4.1.3.0 TinyBooter V 4.1.3.0
• GHI NETMF Library V 4.1.3.0

But isn’t the problem caused by what Windows sees as the hardware ID (…001…) vs what is in the GHI .Inf file (…003…)? the complete hardware IDs are:

USB\Vid_1B9F&Pid_F003&MI_01 what’s in the GHI driver file

USB\VID_1B9F&PID_F001&REV_0100 ID that Windows reports

I am assuming that when Windows checks the driver file and see a different hardware ID it chokes. Any further insights are appreciated.

I remember having issues with this at first. I somehow stumbled on correct order after some uninstalls/reinstalls without ever knowing for sure what this issue was.

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation/Index.html

Per the does, do you need to install the plain CDC driver first, and then additionally install the Debug-CDC driver?

I would start fresh and remove all ghi and drivers. Then reinstall after getting reply on this question above.

Yes please with new thread on forum and post your testing code with explanation of the problem. This should be easy so I am sure we are overlooking something simple

I agree this should be easy and suspect I have neglected something simple. I will post the results in a new thread as I’ve uninstalled, reinstalled several times, tried everything I can think of, and and still can’t get the driver to work - on to a new thread.