Main Site Documentation

CDC VCOM Driver location?


#1

Hi! I know this has been discussed, but I’ve not seen an answer that provides clear direction, so…

Where does one get the CDC VCOM drivers needed for using a FEZ Spider and USB DP Client as a CDC VCOM port? This is what my computer’s looking for:

USB\VID_1B9F&PID_F001&REV_0100

However, I have no .inf file that knows what driver to use. I’ve seen that the drivers are supposedly on my system, but would love to find the associated .inf.

Help?


#2

The link in documentation of USB client CDC feature will send you to http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation%20v4.2/Premium/CDC_Driver.inf


#3

Hi Gus, I’m sorry - I just can’t find that. The link you provided works clearly. (Thank you) But, I can’t find a document under the USB Client CDC page that points to it. Maybe I looked in the wrong place:

ghielectronics.com->buy online->modules->usb dp client module->documents

Is that what you’re refering to?


#4

Look at the documentation USB Client -> CDC

Here is a link

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation%20v4.2/Premium/html/40d1d6f6-c393-cf13-daf1-a4a6fea2a272.htm


#5

Ah - I see. I thought it would be linked near the example tutorial code. But, it’s in the NETMF docs. Thanks for the clarification.

I made a .inf file and copied it into the following directory:

C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb

Is that needed? Or can I just put the .inf wherever convenient?

Also, I now see a com port for the CDC VCOM device. But, using putty (what a great program) I can’t open that serial port. I checked the speed, parity, bits, etc and that all matches. (I am successful in using putty for a BT SPP connection.

Any pointers?


#6

Strange. Can you try teraterm?


#7

Sure. Downloaded ttperm23.zip, unzipped it and installed it. Changed the VCOM port to 2, since Tterm only works with ports 1-4 and 3&4 are already in use.

Same result: can’t open serial port.

A puzzler…

Oh - and now that I’ve installed the VCOM driver, the code thinks it’s connected and writes to the (non-existent) serial device (well, non-visible) :slight_smile:

And, some more info: Win7, 64 bit OS.


#8

Hello, I tried a simple example and see that it is working well. Test on Win7 - 64bit too

[quote]Tterm only works with ports 1-4 and 3&4 are already in use.[/quote] => You mean TeraTerm? on my side port 45# is good.


#9

This is the teraterm we use http://www.ghielectronics.com/downloads/general/teraterm_utf8-4.53.exe


#10

I’m traveling, but will download the (greatly) updated TTerm and try it as soon as I can. Like Dat, I see the device in the device manager as a CDC device, on whatever port. But, when I try to use a terminal program, it doesn’t hook up. Thanks for the new pointer, and I’ll let you know what happens!


#11

Interesting. If I use the code sample, which merely streams a connected message, I can make that work. But, if I try the following:


            int i = 0;
            byte[] bytes = System.Text.Encoding.UTF8.GetBytes("Connected to FEZ Spider!" + i++.ToString() + "\r\n");
            // Check if connected to PC
            while (true)
            {
                while (USBClientController.GetState() != USBClientController.State.Running)
                {
                    debugLCD.Print("Waiting to connect to PC...");
                    Thread.Sleep(3000);
                }
                debugLCD.Print("Connected via CDC");
                cdc.Write(bytes, 0, bytes.Length);
                //break;
            }

I see on my DebugLCD output that I am connected. However, I never get output in the serial terminal.

And, is there a way to know that someone has send data to the CDC port? That is, some callback like bt.DataReceived += new Bluetooth.DataReceivedHandler(bt_DataRcvd); for bluetooth?


#12

For receiving, you need a thread that loops every 10ms and read the data.


#13

thanks, Gus. Any thoughts on why output doesn’t show up?


#14

No but Dat maybe able to help


#15

I checked and it seems we have a problem with CDC VCOM driver. we are looking into it further.
Thanks for your feedback.


#16

Looking forward to a resolution. :slight_smile:

Is there a prize for finding problems?


#17

What about some beer? :slight_smile:


#18

@ Gus - Sign me up… One beer for the VCOMM driver problem and one for the persistent storage problem. :slight_smile:


#19

@ Dat - Any updates on this topic?


#20

@ jzeevi -

One beer for the VCOMM driver problem and one for the persistent storage problem. :slight_smile:

what is “persistent storage problem”?