CANxtra support thread

Thanks Gus, works perfect.

Am I correct that there is no 5V on the DB25 connector?

Yes no 5V


Other question, is there any keypad out there that is compatible and can be plugged into the CANxtra keypad connector?


I doubt it but you can hack in a keypad. See schematics for available IOs

Another couple questions.

  1. On the CANxtra brochure I see the pinout mentions AD1 on pin18, though VS doesn’t enumerate AD1 (see image).

  2. is there a way to avoid the error saying “FEZ Cobra not detected” while deploying? (it deploys if you press continue, it’s just annoying)

  3. Seen there’s no 5V on the DB25 connector, pulling 5V of the USB Host connector won’t do any harm i suppose? (to feed 2 LM35DZ temp sensors (2 x 60 microAmps))


Why using fez cobra dll with canxtra?!

Ok, got that error sorted out. What about the other 2 questions?

BTW, I have a webserver running on the CANxtra including JQuery refreshing temperature values on an html page. It’s a neat little box.

Use the analog pin enum to get ad1 or just use number 1

You can take 5v fromusb host up to 200ma

Yep, canxtra is great :slight_smile:

Don’t see it in the schematic, but is there a way to detect when a card is inserted? (interrupt?)

Just found this answer from Gus:

So there isn’t any other way then doing PersistentStorage.DetectSDCard()

Quick CAN related question. What do I need to do to connect my CANxtra to a CAN bus of a car? CAN1H and CAN1L from pin 24/25 of the DB25 onto the in-dash connector (of which I haven’t searched for to confirm what connector/pinout it might be).

Hardware speaking, yes that is all you need. For software, you need to know a bit of info about your car’s bus.

Looking at doing that myself too on my Opel Zafira soon.

I am trying to update the CANxtra firmware.
I send a stream of % using tera term on the COM port using the settings given.
There is absolutely no difference between me doing this and powering on normally

Please help, I’ve read this thread & instructions through again and again to no avail.

Hi SaltyPete

lets step back to first principles and step through the important things.

When you connect the device via USB, what firmware version is shown on the LCD?

You have to use the serial cable that came with the device, did you do that? Does your PC have a DB9 serial port or are you then connecting that cable to a USB–>SERIAL adapter?

What port is either your DB9 or USB/Serial connector advertise? Open device manager and confirm.

You have to then open TeraTerm or similar and set up the port you want to use, and the settings of 115200/n/8/1.

Then unplug the USB cable, hold shift and 5 keys down so % gets sent a lot, then plug the USB cable back in.

Then you should see the GHI Bootloader messages:

[quote]Force Boot Loader detected
GHI loader commands are now active
and the LCD will not show anything.

Hope that helps - let us know what you find !

The Problem was with the computer’s connection to the COM port. Using a different computer the update worked.
Thankyou for your help

I’m trying to upgrade the firmware on my CANxtra. I’ve been able to connect with the serial port, and erase the memory. After I upload the TinyBooter code sucessfully, I receive another BL prompt. The documentation says this means the TinyBooter update process failed. The computer also does not recognize the CANxtra using USB so I assume that’s because the TinyBooter didn’t update correctly. What might be causing this? Is it ok to have the CANxtra powered by the USB port during the update process? TIA.

Maybe power is not sufficient. Try powered hub or eternal power.

I’ve tried it with with external power and with a powered hub and had the same results. The BL prompt is displayed immediately after the TinyBooter upload indicates success. As an aside, I also saw that the CANxtra Readme.txt says the bootloader uses COM2 but it seems to be using COM1 on my computer. Any other ideas?

Maybe file is corrupted. Maybe you did not select 1k option. Maybe you are not using terarerm from our website. Maybe you do not have admin rights do copy the firmware file to desktop. Maybe you are selecting the wrong file.