Main Site Documentation

Can't update Spider firmware because board isn't recognized in 'Loader' mode


#1

When I switch the configuration to ‘Loader’ mode, my PC is unable to recognize the device. It is shown as ‘Universal Serial Bus controllers’ / ‘Unknown Device’.

In the device status in device manager, I see the below.

When I switch it to ‘Default’ or ‘Tinybooter’ mode, the device shows up as

I’m running on a 64 bit Windows 7 box with 8GB of ram.

I have the USB card hooked to socket 1 and directly connected to the USB

Any ideas? I can try it on another box monday.


#2

I tried a few more times, and it finally recognized it!

Weird.


#3

what is the speed of the processor in your PC? USB 2.0 or 3,0?


#4

Hi,

Same problem here, the PC doesn’t recognize the module when in loader mode (shown as “unknown device” in the devices manager).
Tried uninstalling / reinstalling, impossible to update the drivers.
However, it’s well recognized and works fine in default mode.

I use Windows 7 64 bits. The module is connected mainly through a powered USB 2 host, but I have the same behavior connected directly on the main board USB 1 or USB 2 interfaces.


#5

Try loading the drivers manually.


#6

Thanks Gus for your kick response, but if I try to manualy select the [italic]GHI_Bootloader_Interface.inf[/italic] in the [italic]Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface[/italic] folder, Windows says the folder doesn’t containt any compatible driver, or the driver is not for X64 machines.
For your information, the [italic]…\GHI_Bootloader_Interface[/italic] has no sub folder, but the[italic] …\GHI_NETMF_Interface[/italic] has sub folders x64 and amd64 containing .sys files. Is it possible that some files would be missing in the setup ?


#7

Maybe rest the pc?


#8

Already tried rebooting the PC.
Can anybody tell me which files / directories are in the [italic]Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface[/italic] ?
Still can’t even test my 2 month old wifi module :frowning:


#9

There is 2 files, inf and cat.


#10

Hope you don’t mind me continuing with this thread as it is fairly recent.

I got myself into a silly position where the system was constantly rebooting. I have deleted all code and hoped to start again from scratch (Using the bootloader and a terminal program). My computer does now recognise both the loader and debug interfaces.

I now need to update firmware because I had deleted it but the firmware updater does not recognise the board. I don’t think I updated the board when I first started a few weeks ago.

When I start up the updater I get 2 consecutive identical error messages like the one attached. It then starts up apparently correctly.

Any thoughts,


#11

Your pc may not be up to date with latest updates. Try to update the firmware manually instead of using the updater program.

Look for “firmware update” under tutorials.