Can't install netmfvs2013.vsix

I recently upgraded from Windows 7 x86 to x64. I’ve had to reinstall everything, including Visual Studio and netmf. Running VS2013 express, I was able to install MicroFrameworkSDK.MSI out of the netmf-v4.3.2-SDK-QFE2-RTM package, but netmfvs2013.vsix crashes with the following fault:

System.MissingMethodException: Method not found: ‘System.Collections.Generic.IEnumerable`1<System.Security.Cryptography.X509Certificates.X509ChainStatus> Microsoft.VisualStudio.ExtensionManager.IInstallableExtension.get_InvalidCertificateInformation()’.

I then noticed that the install directions on the GHI support page calls for VS2013 Community. I uninstalled Express and installed Community, but I am still getting the same error. I’ve reinstalled VS several times now, rebooted between installations, but I always get this error.

Google has failed me utterly with this error. Can anyone help?


Posting the solution so anyone else with this issue will see it. The problem was that I had previously installed Visual Studio 2015 on this system. When I opened the Task Manager and opened the properties for the task that was giving me errors, it pointed to the VSixInstaller.exe found in the Visual Studio 14 folder. When I opened the vsix file manually with the VSixInstaller.exe in the Visual Studio 12 folder, it worked.


Have some exp points for your troubles.

Also, update your profile; let us know more about you.

Thanks for the XP! I’ve updated my profile, per your request. Warning: I’m a pretty boring dude!

Obviously you aren’t that boring if you are chatting it up on this forum! ;D

You seem to be less boring than me.