Can't get +5v from FEZ Raptor socket pin

Hi guys! fez is powered with ni-cd battery pack 8.4v through client dp module. I need to get 5v from Vout pin on any socket, but it gives only 4.84. What is the problem? Thank you.

that isn’t a problem for modern electronics, it’s within spec.

Your issue is explicitly because you have a motor that needs 5.0 and no lower. You’re going to need your own regulator.

Vout is a signal source, not a power source. You can’t use this pin to drive anything.

To control motors, use an h bridge, connected to PWM pins.

1 Like

I think he is referring to the +5V output on each socket on PIN 2, is this correct Alex?

If so, then the voltage on these pins will be the same as the DP output to the board.

How much current do you need at 5V?

1 Like

@ Dave McLaughlin -
Yes it is, you are right! I need +5v output on the socket. I don,t know how much the current should be, but not to much i think. I want to power the steering servo thats it.

I have no idea why DP output is 4.84… I use powerful battery pack (5000 mAh, 9v). Is the dp output special limited by design?

4.84 is in spec for a 5v processor/sensor. You’re trying to power a servo that needs it closer to 5v. You should just use a secondary power supply with your own VREG with sufficient capacity for your servo. Or you could even use the 8v you have from the battery, that should also suffice (servos are usually able to run with greater voltage than 5v, but make sure you have a spare in case :wink: )

1 Like

@ Brett -
I think this servo is up to 6v. Can you advice VReq please?

@ Gus -
Is H-Bridge a gadgeteer module? I didnt find it in the list.

You need to know the current of the servo first.

The DP Module is able to provide max 800mA at 5V (it will get hot at this temp though). The voltage drop is likely due to the TSP2115 switch that is used to swap from USB and EXTERNAL supply. It has a switch on resistance of 0.084 ohms. You could also check the voltage of the regulator on the DP module. Measue this across R7.

If your servo is only around 100mA it should work with the 4.84V you are measuring. Torque will be a little less but should still work.

1 Like

Sorry for a lot of questions, but i’ve never used external source to power a servo. How the supply scheme should look? Have a look on the scheme i am going to make please (attached), and correct me if i am wrong somewhere. I just want to make sure i am going towards the right way before i burn something.

I dont know the mA of my servo, but when i power it with ESC +5v source it works. I have to avoid the ESC power supply scheme and trying to find another way, because of the power draw, that influence on steering servo when ESC is fully loaded. I will attach the power supply scheme i use, it works pretty good if the ESC is not fully loaded (50%, 75%), but when the ESC is loaded to 100% steering servo start to turn right or left by itself.

Please take a look on attached scheme, maybe you can advice what shoul i do to fix the power draw problem. Thank you.

as I said, be prepared that you could fry the servo (hopefully it’s just a cheapie and you have a spare or two - you’ll probably want them over time anyhow :slight_smile: ) If the one in the picture (SF-20?) is the real one you have, they talk about it as being a 6v rated servo, so directly connecting a 8.4v pack (which may be closer to 9v when fully charged) has a big chance to go wrong, certainly not reliable over time to do that.

You can of course buy a separate regulator 5V Step Down Voltage Regulator - ServoCity for example (or cheaper ebay equivalent like perhaps). Power the ESC, the regulator, and the DP module with the battery pack. Remember that ESCs create lots of noise and can draw lots of current, so you don’t want to try to power a microcontroller directly with it’s output, the DP should keep the voltage into the Raptor stable

1 Like

Thank you for reply! The pictures on my scheme are not real. But i won’t try to power the servo without step down voltage regulator it will damage it for sure (read the article on another forum). I’ll follow the links you provided, that i was looking for.

Now i have another problem, i tried to use different P socket to control the steering servo to avoid the possible noise and power draws from ESC as Gus suggested in another thread: [url][/url]
And i found that PWM9 on X16 socket doesnt work. I run the same code as i used for X18 socket, slightly change it to X16 socket, connect the power to steering servo, connect the GND and servo PWM wire to X16 and it doesnt start the servo. I also tried to run the ESC on X16 socket, the same result…

According to specs, raptor has 4 hardware pwms (three of them 7,8,9 sit on X18, one of them 9 sit on X16 socket), if my PWM9 doesn’t work on X16, is it possible to use the other not “P” socket as PWM? Because all working PWM sit on the same X18 socket, but i want to use a different socket to avoid noise as Gus adviced.