Main Site Documentation

Cannot update spider!


#1

Hi,

I bought myself a second spider but it won’t update! I used the updater that’s with the sdk. Put all the sockets in position and tried an external power supply.

The board is recognised as a device, it pings on mf deploy and will try to upload fine. It’s also found in loader mode.

I get the following if I try to upload code which I assume means I need an update:

code ssembly: GTM.GHIElectronics.Camera (4.1.1.2) needs assembly ‘GHIElectronics.NETMF.USBHost’ (4.1.8.0)…

and so on…

The screen say’s i’m on version 4.1.7.0

Very frustrating! Any help is much appreciated.


#2

Just to double check you did download the latest SDK?

http://www.ghielectronics.com/downloads/NETMF/GHI%20NETMF%20v4.1%20and%20.NET%20Gadgeteer%20Package.zip


#3

yeah I already have that one installed and am trying to update the firmware on the second board.


#4

Did you get any errors during the update?


#5

Could you please take a picture of the on-board configuration switches. I would like to make sure you used the correct configurations before using FEZ Spider updater.


#6

Also one more think to try:
make sure you have all of your windows minimized when you try to update the spider because sometimes windows will try to install the Virtual Com Driver and pops a window that sits under all other windows where you can see it to click OK.

Cheers.


#7

I get cannot connect to device please follow steps 1 and 2.

I hope I’ve got them in the right place!


#8

I get cannot connect to device please follow steps 1 and 2.

I hope I’ve got them in the right place!


#9

sorry my browsers playing up…


#10

The switches looks fine. When you plug the USB cable what do you see in Windows device manager?


#11

It say’s its working properly
Driver version: 1.0.0.2

Is this all I should see.


#12

hmm. I don’t see the Virtual COM port for GHI bootloader interface.
With this switch configuration, try to ping using MFDeploy. You should be able to do that.


#13

It’s pinging fine.


#14

Should I try and reinstall the drivers?

The other board I have is working fine which seems strange to me.


#15

If the switches are as they are in the image you posted (the one on the left is the only one up). then you should not be able to ping because it should be in the bootloader mode.
You need to reset the board after you change the configuration switches. Did you do that?


#16

I reset the board with the switches in that position (one on left only up) and it still pings…

Pinging… TinyCLR
Pinging… TinyCLR
Pinging… TinyCLR

It sill does not update. Not sure if it’s relevant but the screen say’s “Waiting for debug commands…”


#17

While we are looking for the reason, please do these steps:

  • Set the configuration to the default mode.
  • Reset the board.
  • Make sure you can ping.
  • Click Erase button (it is on the right of Ping button)
  • Reset the board.
  • Run Spider Updater Application and follow its steps.

Hope this can help.


#18

Do you see the same issue on both FEZ Spider mainboards that you have?


#19

I managed to update the other board fine and then tried this one straight after but it wouldn’t.

Dat I tried that twice and it does not seem to work either.

It erases fine and I reset it, then it pings but it won’t update.

If it’s possibly a PC issue I’ll try a different one later.

Can I do this manually with MF Deploy and is it easy enough? Or am I likely to have the same problem.


#20

Thanks for everyone’s help but this board just won’t update.

I just tried it on another laptop with a new install and power supply with no luck. Same problem of it not connecting to the device.

Is there a way to do it manually or will it give me the same problems?

Is there anything else I can try?

Unfortunately I really need to make a prototype quick!