Cannot create .NET Gadgetter App. - Just get error message


Installed all the software, no problem. When I try to create a new project and select C# and .Net Gadgeteer App (NETMF 4.2) . I get an error message that it cannot open a file that ends with .csprog and that that file type is not supported (see attached image of error message). Can’t go any further.

Did you use visual studio we listed under downloads?

No I have Visual Studio 2010 Pro already installed on my machine

That should work!

Hi Gus,

The project type Gadgeteer show up under C#. When I select the Gadgeteer type I get a choice of NETMF 4.1 or NETMF4.2. Since I am using the Cerburus I choose 4.2.
I seems like it might be a permission problem. I am using Windows 7.

The error message says:

The project type is no supported by this installation.

Looking in the folder:

C:\Users\David\Documents\Visual Studio 2010\Templates\ItemTemplates

I don’t see any templates for the Cerberus. Should there be something there?


@ davidwood3 - can you create a standard big bother c# project without issue?

@ davidwood3 - are you running VS as administrator?

Did you install netmf?

Hi guys,

I installed the Microsoft NETMF 4.2 SDK and it worked. I had already installed the GHI NETMF 4.2 and Gadgeteer, but it seems like you need both.

It appears to be working now.

Thank you very much!!!

I have installed both the sdk and GHI NETMF v4.2 and .NET Gadgeteer Package (10-24-2012), but I am still getting the same error
"Device not found or cannot be opened - USB:Gadgeteer========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========
Few inputs:
while creating the project, I choose NETMF4.2
I had the problem device not being recognized by win7 like few others, and followed the blog’s, resolved it by updating the drivers manually by pointing to suggested location.
I get the click sound when I connect the device to the system.

Any suggestions please.

Thank you.

Please start a new thread.

(but in the meantime, your image shows it doesn’t have a netmf firmware on it, it’s in bootloader mode. Looks like you either need to get out of bootloader mode or put netmf firmware on it)