Cannot connect to FEZ Spider

No matter what I do I can’t get my Spider to connect anymore. I’ve got it down to in Device Manager GHI Bootloader Interface (COM3). It says that “This device cannot start. (Code 10) (Operation Failed.) The requested operation was unsuccessful.”

I’ve tried updating the driver, but it says it is current. What else can I do?

Thanks kindly,

@ lelandholmquest

Have checked if the bootloader and the Firmeware have the same version?

Have you tried another USB port? On a different machine?

Additional Information:

Perhaps You can try to switch your Spider in Bootloader mode (see configuration switches) and try to flash with last firmware.

hi lelandholmquest

welcome to the forum.

I see you’re already putting the Spider in bootloader mode (hence why Device Manager shows that).

Can you tell us about the history of the Spider and your PC? Have you recently upgraded or rebuilt the PC or OS ? Have you recently upgraded VS versions, netmf SDKs, or GHI SDKs?

There have been some previous cases (but I don’t think there’s a complete understanding of what the combination is) where a device connected to a USB3 port will not work. Are you connecting to a USB3 port by any chance ?

First thing that I think you should do is try connecting the device to another PC - even one that doesn’t have the software installed, and see what Device Manager shows in that case. There’s also a few instanced been reported where the software install hasn’t worked, so if you uninstall ALL the software you have including drivers, and reinstalling them and keeping an eye on successes/failures might assist. But als omake sure you check out the troubleshooting guide

good luck - we’re here for you and we’ll all help to get you working again !