Main Site Documentation

Cannot connect Panda II with my PC


#1

With my PC / Windows 7 64 bit I try since hours to connect (throught MFDeploy or visual studio) to my new Panda II.
I have installed Microsoft NETMF 4.1 SDK, GHI NETMF v4.1 SDK and GHI NETMF USB Drivers 64-Bit (from this page : http://www.ghielectronics.com/catalog/product/256)

When I plug my Panda II with USB => Then it is recognized as “USBizi” during one second (USB plugged windows sound), then displappears from the list of hardwares (USB unplug sound).
If I boot my Panda II in LDR mode, then in my hardware list appears “GHI Boot loader Interface”… But I it is not pinging with MFDeploy using serial

To be sure I have disconnected all other USB devices connected.
I have also tried all this with another PC (windows 7 also). Exactly same result.

Do you think there might be a problem with my Panda II?

Note that I am either particulary unlucky, or stupid, because this kind of thing already happened to me few monthes ago with a Panda I.


#2

Reliable power source?


#3

MattJack2, I don’t believe MFDeploy does return a successful ping when you are connected through the bootloader VCOM port, so I don’t think that’s part of your problem.

Have you tried reinstalling or updating the driver? How is Device manager identifying the device?


#4

I had a similar problem with win7 and Panda II. It was resolved by downloading FEZpanel and using it to reinstall the new firmware for the Panda. Tera Term would not work on my win7 rig but would on one of my Vista rig.

Others have reported the same issue.


#5

Try another USB cable if you haven’t, my Domino acts up like that sometimes.


#6

Had the same problem. For some un-forseen reason I had to plug the panda into another USB port and it work fine.


#7

Try to update it first to latest firmware with FEZ Panel, then try to connect again.

Also I had problem when Panda II just stopped recognizing in Windows 7 32-bit with “USB Device not recognized” message and led was always on. I thought its burned. I tried with USB hub and direct USB.

But then I disconnected all devices from the hub (printer, ipod and android phone) and it started working again!