Can not Updat G120E Dev Board using FEZ Config on Windows 10 Pro

I am updating G120E Dev Board using FEZ Config on Windows 10 Pro
after final stage of upload, it tries to reboot and display a dialog as follows:

FEZ Config

The USB driver may not have installed correctly. Re-installing the USB driver may solve this problem.
Or you can try:

  • Power off you device.
  • Reset your PC.
  • Power on you device.
  • Then try to follow steps 1 to 2 again

Prior to upload I did the following:
Power on
Press buttons p2-10 and p0-22
Press Reset
Release buttonsp2-10 and p0-22

I have tried it numerous times and I get the same result!
Also, changed the USB 2.0 port to different one and still getting the same results.

I tried Dat’s recommendation:
"- Enter Bootloader mode

  • Open teratem
  • Select correct port
  • Type “E”
  • Type “Y”
  • Wait for “Done”
  • Type “X”
  • Point to G120\Loader.ghi (select 1K)"

Everting seems to load fine. here is screen capture from Tera Term:

Force Boot Loader detected
GHI loader commands are now active
Erase all memory! Are you sure?

Start File Transfer
File Transfer Finished Successfully

Now, I load the FEZ Config, It still not recognizing the board (see the attached image).

I am completely stuck and can not use the G120E board. Any suggestions? What am I doing wrong?
Thanks for any help.
:wall: :wall: :wall: :wall: :wall: :wall:

@ bghavami - Did you use the XModem protocol in TeraTerm? Once you use TeraTerm to deploy Firmwares\G120\Loader.ghi using XModem 1K and reboot the board, does anything show up in the Device Manager?

I did use Tera Term’s XModem and uploaded Firmwares\G120\Loader.ghi
1’st I thought the file might be corrupt, so I Uninstalled, downloaded both GHI Electronics “NETMF SDK 2016 R1 Pre-Release 1” and “netmf-v4.3.2-SDK-QFE2-RTM” files and installed them again. Is there any reports of problems on Windows 10 Pro 64bit?

I tried the transfer with old copy from your site and the new one on the official Tera Term site, each gave me different results. The old one always fails with lots of BL’s the new one finishes “File Transfer Finished Successfully” without any BL’s. After it is finished, Tera Term would not accept key board input, which I assume the script executed a “R” command automatically!?

Device Manager image is attached. When I reboot the unit, both serial ports are grayed and USB port G120 is up and running.

Thanks for quick response.

@ bghavami - Using the new TeraTerm that finishes successfully, load Loader.ghi. Reboot the board so you see the G120 in the Device Manager like in your screenshot. Instead of going to FEZ Config, open MFDeploy and ping the board. It should come back as TinyBooter. Once it does so, try to deploy the firmware using MFDeploy. The firmware is Firmware.hex, Firmware2.hex, and Config.hex under C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\G120.

When I ping from MFDeply I get No reponse. See the images.
The same is true when use MFDeploy with serial port.

I have run across this issue with a few (other) devices as well. What I have done to fix the problem is to delete all the (G120) devices in the device manager. Unplug the G120, reboot your PC. After the PC reboots, plug in the G120 and let Windows discover the device and install the drivers.

This has worked for me in the past.

I deleted G120 from Device Manager, disconnected G120E from USB port, rebooted the PC, logged in, plugged G120E back. The system loaded a new copy of device driver for G120. Using MFDeploy, the USB port is not recognized, I held down P2-10 and P0-22 followed by reset and released P2-10 and P0-22. Now MFDeply sees the COM11 and noting else works (can not ping or use the USB as usual). see the images.

Thanks for any help.

Did you delete all G120’s including the hidden ones?

I deleted all hidden one’s too. Totally clean (marked it to delete files). Look at the Device manager’s image on previous post.

I really appreciate you trying to help.

Can you zip a copy of latest Loader.ghi for G120E and make it available to me? I think the one in the install is corrupt. What do you think? Do I need any other files?

@ bghavami - The MD5 hash of Loader.ghi in the latest 2016 R1 Pre-Release 1 is 273C2988CFB2D5DE0578495CFFCD5556. Can you connect USB to the COM1 port on the board and put the board into serial debug mode using P2.1/MODE on the 40 pin header? Connect to the board using MFDeploy (press F5 when the COM port is selected and reboot the board). You should see startup information if it works correctly.

Hi John,

Here is the result:

TinyBooter v4.3.1.0
G120 Build Date: Dec 23 2015 10:53:33
ARM Compiler version 410713

What do I need to do next?

@ bghavami - Try to update the firmware using MFDeploy and the serial interface.

There are three hex files (Config.hex, Firmware.hex, and Firmware2.hex) which one do I need to deploy?

I selected all three files (see the image) and I got an error (see the next image)

@ bghavami - All three files are required. Are you still able to ping device after you got the error?


It did respond to the ping:

Connecting to COM4…Connected
TinyBooter v4.3.1.0
G120 Build Date: Dec 23 2015 10:53:33
ARM Compiler version 410713
Pinging… TinyBooter
Bootloader build info: Copyright © GHI Electronics, LLC

What does it mean?

@ bghavami - Can you try to deploy one more time after the successful ping?

It worked halfway! It finished loading Firmware.hex and displayed the same error message in a dialog box (see the image in the previous post). used 9600,8,1 baud and no handshaking.

@ bghavami - If you try a few times, does it fail in the same spot every time? If so, it seems like the flash on the module is damaged.

I think you are right. When I connect to G120E using MFDeploy and press F5 I get a scrolling list of exceptions (see the image).

what do we do now?