Main Site Documentation

Can not create project in Visual Studio 2010 Professional


#1

When I try and create a new Fez Panda II project in VS Pro I get the following error

The project type is not supported by this installation.

I use VS2010 pro on my home machine and it works fine, but when I try and open the same project on my work machine I also get that same error.

I have re-installed the .net SDK and the GHI sdk but it will not solve the issue.

I do have VS2010 Express on my machine as well and I can open these projects in that. Is it not possible to have both Express and Pro on the same computer? I am afraid to remove the Express version as that is the only way I can work on my Fez projects right now.

On my work machine this is the sequence of installations

Installed 2010 express and the GHI SDKs was developing USBizi projects for a while
Purchased 2010 pro and was doing some windows development
Tried to load my Fez projects created with express and got the error above.
Re-insalled the latest GHI sdk, did not fix issue
Re-Installed MS SDK, did not fix,
Re-Installed GHI SDK again, did not fix problem

If I remove the ProjectTypeGuids from the .csproj file then the project will load but I am missing the .net Micro Framework tab on the project properties.

Anyone have suggestions on how to fix this?

Thanks
Shawn


#2

That error seems to indicate that you do not have the NETMF SDK installed (or installed properly). A quick command you can run from a Visual Studio Command Prompt is:
devenv.exe /ResetSkipPkgs
Thats should reset all the packages you have installed. If that does not help, then I would uninstall all the NETMF, Gadgeteer and GHI SDKs/Tools and resinstall them in order or use the main installer in the GHI SDK which will install all the SDKs/Tools in the proper order.


#3

It could be that the SDKs installed themselves only into Express version of VS, rather than both. So uninstalling Express may help you as well (prior to reinstalling all of the SDKs).